2

When I change some settings in Options - Configure Texmaker and close the window, my changes aren't saved, and there is no "save settings" button as far as I can see. More specifically, I am trying to switch to an embedded pdf viewer, which of course doesn't happen when I am unable configure Texmaker myself. How can I make it happen?

I am using Texmaker version 5.0.2 on windows 10.

6
  • Try TexStudio. I find TexMaker developer problematic to deal with. – ajeh Aug 18 '17 at 14:34
  • I'm using TexMaker on a mac, but here the button saying "Ok" is in the bottom right corner. Are you sure, you see the full window? Can you double-click on the top of the window to maximize it? – Ben Aug 20 '17 at 23:28
  • 1
    Try Enter in any text box. This saves my edits without clicking on "Ok". – Ben Aug 20 '17 at 23:36
  • Thanks @Ben, that solved it! Looks like everything menu-related in my texmaker is scaled up to 150% size or something, moving any ok-button outside the screen. – mss Aug 23 '17 at 14:30
  • what about for Macs? – Charlie Parker Feb 1 '18 at 19:18
1

There is a save button. Maybe its not being displayed because of the display settings.

Go to display settings in the settings app, There is an option called scale and layout. Change it to something less than the current value. 150% is recommended so try setting it to 100% and open the configure window in TeXmaker. Now you should be able to see a save button at the bottom.

1
  • I went to the file menu and its unhighlighted so I can't save – Charlie Parker Feb 1 '18 at 19:19
1

I had the very same problem. For me the reason was that I copied/installed the TexMaker binaries (from a 5.02 USB version of TexMaker) into my "Programs" folder. This folder is write protected by the Windows OS. The INI-file settings will get stored next to the binaries of TexMaker. So, they can not be written without raising the UAC rights of TexMaker.

Solution for me:

  1. Go to the "texmaker.exe" binary somewhere in the "Programs" folder, right click it in the Explorer and choose "Run as administrator".
  2. Apply some settings and save them. Now those settings will get written.

Please note that those lower UAC rights also apply in cases, where you start some TEX-files directly from the Explorer after setting the "standard TEX-file linked application".

I do not know if this a special issue of the USB version of texmaker or a general one.

Cheers!

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.