0

I'm preparing a document using the acmart.cls class file of ACM. When I compile, it keeps showing me this warning:

Class acmart Warning: You do not have libertine package installed. Please upgrade your TeX on input line 611.

However, I can still compile, and get the pdf file. To get rid of this warning, I tried to install libertine. It then requires several other packages including biolinum-type1.

Now when I compile the file again, I got several errors, not warning.

! LaTeX Error: Unknown option `tt' for package `biolinum-type1'.
! LaTeX Error: Unknown option `type1' for package `biolinum-type1'.
! LaTeX Error: Unknown option `tt' for package `libertine-type1'.
! LaTeX Error: Unknown option `type1' for package `libertine-type1'.

I couldn't get the pdf file.


Update: I'm using Ubuntu 17, and my latex version is:

pdfTeX 3.14159265-2.6-1.40.17 (TeX Live 2016/Debian)  
kpathsea version 6.2.2

Update 2: I accidentally figured out the problem. Actually I do not understand why there is the problem. But there is a package called newtx, and if I deleted it, the errors above disappeared, and I could compile a pdf file.

However, I installed newtx because acmart told me to do so. After I delete it, now I have the warning.

You do not have newtxmath package installed. Please upgrade your TeX

  • I think you have to give more info like your Operating system and the versions+kind of latex+packages you are using (texlive and pdflatex etc) – koleygr Aug 18 '17 at 23:58
  • @koleygr: I just added my set up. – qsp Aug 19 '17 at 0:05
  • This info will be needed to the next one who will find your question. I thought I could just download a cls file to test it but it is more complicated. (your ubuntu is called 17.04 -year and month- but it is clear anyway) – koleygr Aug 19 '17 at 0:23
  • Did you install libertine from ctan.org/tex-archive/install/fonts ? Note that ctan.org/pkg/biolinum-type1 says that this is obsolete so I imagine you shouldn't see this if you have a recent version of libertine. – rocky Aug 20 '17 at 1:17
  • 1
    On Ubuntu, if you’ve downloaded an old version of the packages and installed it manually, uninstall that. Then use aptto install either texlive-full, or at least texlive-fonts-extra, which contains the libertine and newtxmath packages, and texlive-publishers, which contains the acmartclass and its prerequisites. See if you need any other TeX Live packages while you’re at it. – Davislor Jul 16 '18 at 20:31
0

My guess is that you installed an old version of libertine. Reinstall a new one from https://ctan.org/tex-archive/install/fonts

The CTAN information on biolinum-type1 says that is obsolete. From https://ctan.org/pkg/biolinum-type1 :

The pack­age (and the com­pan­ion lib­er­tine-type1 pack­age of serif fonts) re­placed the lib­er­tine-legacy bun­dle. How­ever, the pack­ages do not pro­vide the range of font shapes avail­able with lib­er­tine-legacy. The pack­age is now su­per­seded by the au­thor’s lib­er­tine font pack­age.

Also, I suspect you might also be able to ignore messages about a missing libertine. When I recently did using on a paper using acmart and option acmtogs, I got that message too and was able to ignore it.

However since you happen to be running this on Ubuntu, I'll add another tip. I needed to install install to texlive-xetex in addition to the other texlive debian packages.

One tool you might be able to use to help you track down problems is the system checker in kile. So run

$ sudo apt install kile
$ kile

Then inside kile, in the very top toolbar (on my desktop it appears at the very upper left corner), select SettingsSystem Check and that will give you some idea if you've installed TeX and LaTeX properly.

  • I did all you said. The problem persists. Kile's system check stopped at 29% and never finished. I installed texlive-xetex, but it doesn't help. – qsp Aug 22 '17 at 23:41
  • Sounds to me like there are multiple things going wrong. And too few details you give or notice about what's up. (These things are perhaps related.) – rocky Aug 23 '17 at 1:42
  • 1
    the transitions from libertine to libertine-legacy to libertine-type1 back to libertine were a head-spinning period... – user4686 Mar 18 '18 at 18:24
  • @jfbu Isn’t that always the flaw with the libertines? “For tomorrow we might die! (But, alas, we never do.)” – Davislor Jul 16 '18 at 19:59
0

If you installed TeX Live packages manually, I’d recommend uninstalling them and letting the Ubuntu package manager keep you up to date. (Make sure Universe is in your list of repos.) Alternatively, do a TeX Live install to /usr/local, make sure its bin directory appears before the system directories in your PATH, and run tlmgr regularly. (If you do this, also put its documentation at the start of your MANPATH.)

By the way, you want to compile acmart documents with xelatex rather than latex.

If you don’t care about the disk space, just install texlive-full.

Since you’re using Ubuntu, a good technique is to search the package database for the package containing a given file. If you want to install only packages you actually need, a search shows that libertine.sty and newtxmath.sty are in the package texlive-fonts-extra and acmart.sty (and its prerequisites) are in texlive-publishers. You additionally will want to compile acmart documents in XeLaTeX, so make sure you have texlive-xetex installed. You also probably want to make sure you have the packages in texlive-plain-generic, texlive-latex-extra, texlive-fonts-extra-links, texlive-formats-extra, texlive-luatex, texlive-math-extra, texlive-pictures, texlive-lang-all and texlive-science. Also install their recommended packages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.