0

TL;DR Why is the first line of every stanza broken after the first character when using astanza from the reledpar / reledmac package? And why is the title missing?

I am currently creating a Latex document in a twoside class which contains a bilingual text: On the left side (the left page) there is always a latin text and on the right side (the right page) there is the german translation. For this I am using reledpar. I have stanzas (astanza) on the left side and the translation on the right side and I always let a headline / title preceed the actual stanza / translation.

I add the title as a parameter to the astanza environment which is therefore passed on to the pstart, because astanza is just a special wrapper of pstart / pend.

Now my problem is that when I compile my MWE locally the first line of every astanza is broken after the first character. Also the title of every astanza is missing. See the following screenshot or PDF.
Broken line and no title astanza
Broken line and no title astanza PDF
I tested this with my local LaTeX installation (MikTex) and TexMaker as well as TexStudio. The reledmac version I have installed locally is 2.24.0 from the 18th of August 2017. I also tried compiling this MWE on sharelatex with all available compilers and always have the same result.

If I use overleaf to compile this, it works totally fine. See the following screenshot or PDF.
Wroking astanza with headline on overleaf
Wroking astanza with headline on overleaf PDF
Now my problem is, that overleaf is really slow and very hard to debug (my output document has around 100 pages). Therefore I can not go on with working only on overleaf. I really do not understand why it is only working on overleaf.

This is my MWE. Every help is appreciated.

\documentclass[12pt,a4paper,twoside]{scrbook}
\usepackage[]{reledmac}
\usepackage[]{reledpar}

% Set stanza indentation
\setstanzaindents{0,0,1,0,1,0,1,0,1}

\begin{document}
    \large
        \begin{pages}
        \begin{Leftside}
            \beginnumbering
                \begin{astanza}%[\centering\textbf{1. POEM1 dial}]
                    verse  verse verse 1!&  
                    verse verse verse 2!&   
                    verse verse verse 3!&   
                    verse  verse verse 1!&  
                    verse verse verse 2!&   
                    verse verse verse 3!&   
                    verse verse verse 88!\&  
                \end{astanza}
            \endnumbering
    \end{Leftside}
    \begin{Rightside}
        \beginnumbering
            \linenummargin{left}
            \begin{astanza}%[\centering\textbf{1. POEM3 dial}]
                This is a translation paragraph\&[\vskip\baselineskip]       
            \end{astanza}
        \endnumbering
    \end{Rightside}
\end{pages}
\Pages
\end{document}
  • 1
    Use the lastet version of reledmac/reledpar. This bug was corrected in v2.19.5 of reledpar. – Maïeul Aug 20 '17 at 8:12
  • ps: see post tex.stackexchange.com/q/385520/7712 – Maïeul Aug 20 '17 at 8:26
  • Thank you very much Maïeul! In that version the problem does not occur anymore. – Naturjoghurt Aug 20 '17 at 11:05
1

After reading the helpful comment from Maïeul and having a look at this post I found out that there were two different versions of reledmac installed by MikTex. The correct version (2.24.0) was installed via the MikTex Package Manager (Admin), but this was not the version that was used by Latex. I also had to use the MikTex Package Manager (without the --admin flag) to update the package for the currently logged in user.
After doing this the problem was solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.