5

this is my first time using beamer.

I copied a template from the sharelatex page on Beamer

Which works, and \begin{itemize} shows bullets

enter image description here

But after adding a few more packages that I need, all the bullets are gone!

enter image description here

What is going on and how can I fix this?

\documentclass{beamer} 
\usepackage[utf8]{inputenc}   
\usepackage{amsmath} 
\usepackage{amsthm}     %Theorem Environment 
\usepackage{amssymb} 
\usepackage{multirow} 
\usepackage{cancel} 
\usepackage{amsfonts} 
\usepackage{graphicx} 
\usepackage{subfigure} 
\usepackage{upgreek}    
\usepackage{mathtools} 
\usepackage{thmtools} 
\usepackage{enumitem} 

    %Information to be included in the title page: \title{Sample title} \author{Anonymous} \institute{ShareLaTeX} \date{2014}

\begin{document}   
\frame{\titlepage}   
\begin{frame} 
\frametitle{Sample frame title} 
\begin{itemize}
\item  This is a text in first frame. 
\item This is a text in first frame.
\item This is a text in first frame. 
\end{itemize} 
\end{frame} 
\end{document}
  • 7
    The mystery is enumitem ... it is not compatible with beamer – user31729 Aug 20 '17 at 22:18
  • 4
    Wouldn't a detective start removing the packages they added one by one until they found the one that caused the problem? :) This is what is called a Minimal Working Example, i.e. a document that contains only enough code to show the problem. Making such an example can often identify the source of the problem. – Alan Munn Aug 20 '17 at 22:33
  • Welcome! Off-topic: subfigure is obsolete. It ought not be used. amssymb makes amsfonts unnecessary, I think. graphicx is loaded by Beamer anyway. I would start by not loading amsthm, thmtools and upgreek with Beamer. You don't want environments which are not configured for Beamer here, generally. Try Beamer's variants first. Those are overlay-specification aware. mathtools loads amsmath. Changes to fonts will not work the ways you see them work in other classes, so start by not changing the defaults used for text and maths. (Adding more symbols etc. should be OK.) – cfr Aug 20 '17 at 22:55
6

beamer has own, sophisticated mechanism to deal with lists (itemize, enumerate, description) which is not compatible with enumitem. Remove this package from preamble and all will work again.

After some cleaning of your preamble the MWE (minimal Working Example) is:

\documentclass{beamer}
\usepackage[T1]{fontenc}
\usepackage{amsthm}     %Theorem Environment
\usepackage{multirow}
\usepackage{cancel}
\usepackage{mathtools, amssymb}
\usepackage{graphicx}
\usepackage{subfig}% if you really needed
\usepackage{upgreek}
\usepackage{thmtools}

\begin{document}
\begin{frame}
\frametitle{Sample frame title}
\begin{itemize}
\item This is a text in first frame.
\item This is a text in first frame.
\item This is a text in first frame.
\end{itemize}
\end{frame}
\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.