0

According to the csquotes package, "the style of all quotation marks will be adapted to the current language" if babel or polyglossia is loaded. For English the default style is quotes, and for Norwegian the default is guillemets. But with the following code both quotes are with quotes, even though the Norwegian quote is embedded in a norsk environment. What is missing here in order to get the default guillemets for quotes in a Norwegian environment?

\documentclass{article}
\usepackage{polyglossia}
    \setmainlanguage{english}
    \setotherlanguage{norsk}
\usepackage{csquotes}

\begin{document}

    \enquote{This is English}.

\begin{norsk}
    \enquote{Dette er norsk}.
\end{norsk}

\end{document}

enter image description here

3

If you want that the quotes adapts continuously to the language you need the autostyle=true option (the default is tryonce):

\documentclass{article}
\usepackage{polyglossia}
    \setmainlanguage{english}
    \setotherlanguage{norsk}
\usepackage[autostyle=true]{csquotes}

\begin{document}

    \enquote{This is English}.

\begin{norsk}
    \enquote{Dette er norsk}.
\end{norsk}

\end{document}

enter image description here

  • Right! I misinterpreted what tryonce meant when I read the manual. – Sverre Aug 21 '17 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.