1

I'm running a Texmaker 4.4.1 on ubuntu 16.04 LTS.

I wrote a front page for my thesis with a Tikz picture inside, the preview of this document in texmaker is good, and opening the document with evince is good too. But the thumbnail in the corresponding folder show me margins that do not exist in my .tex file (I put all margins=0). These margins appear also when I print the documument and I don't want to have them in the printed version. I checked the properties of the printer and there is no automatic addition of margins.

Here is a part of the latex code :

\documentclass[a4paper,12pt]{report}

\usepackage[top=0cm,bottom=0cm,left=0cm,right=0cm]{geometry}

\usepackage[usenames,dvipsnames]{xcolor}

\usepackage{tikz}

\definecolor{Classique}{RGB}{211,236,185}

\begin{document}

\flushleft

\begin{tikzpicture}
\fill[color=Classique] (0,0)--(20.98,0)--(20.98,1.5)--(2.5,1.5)--(2.5,28.1797)--(20.98,28.1797)--(20.98,29.6797)--(0,29.6797)--cycle; 
\end{tikzpicture}

\end{document}
  • 1
    Welcome to TeX.SX! You can mark code in the editor by hitting the button that shows "{}" just as I did in my edit or by manually indenting it with 4 spaces. It might be that your printer isn't able to print without small margins (even if nothing is noted in the printer's driver options). – Skillmon Aug 22 '17 at 11:26
  • 1
    You say "there is no automatic addition of margins". On Windows system, in the print menu window, there is an option which can be set to "Fit", "Actual size", or "Shrink oversized pages". Make sure that is set to "Actual size". – Steven B. Segletes Aug 22 '17 at 11:56
  • It should be noted that no physical printer can print all the way to the edge. You need to print on a larger sheet of paper and cut off the margins. – John Kormylo Aug 22 '17 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.