1

The htlatex way

$ make4ht document.tex "customcfg.cfg, charset=utf-8" " -cunihtf -utf8" "" "-interaction=nonstopmode"

didn't work. Result was:

make4ht:unrecognized parameter: i.

I would also prefer make4ht's own argument system.

$ make4ht -u -c customcfg.cfg document.tex

Maybe this can be achieved by creating custom build file, but documentation (https://github.com/michal-h21/make4ht) for make4ht is somewhat difficult to understand because I don't know lua very well.

2

In the distributed version of make4ht, you must add spaces before options passed to tex4ht, t4ht and latex, so the correct make4ht invocation should be:

 $ make4ht document.tex "customcfg.cfg, charset=utf-8" " -cunihtf -utf8" "" " -interaction=nonstopmode"

I've just figured out a fix for this issue, you can test it if you want to install the development version of make4ht from Github. It should be possible to normally call

 $ make4ht document.tex "customcfg.cfg, charset=utf-8" "-cunihtf -utf8" "" "-interaction=nonstopmode"

without those spaces.

As for the .mk4 build file, you can modify the parameters to LaTeX using settings table. The following .mk4 file suffices:

 settings.latex_par = settings.latex_par .. " -interaction=nonstopmode"

The latex_par variable contains parameters with LaTeX command line options.

  • Great! The development version from github seems to fix the problem. Thank you! – Jarno_C-137 Aug 23 '17 at 1:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.