1

I'm trying to have no indentation in first line after section title. Changing the argument of \setbeforesecskip and \setaftersecskipto positive and negative value seem not to help (just "1sp" in\setaftersecskip gets some results but section title looks different then).

I noticed it's a tricky topic in memoir.

\documentclass[10pt,twoside, openright,twocolumn]{memoir} 
\usepackage{lipsum}

% Section rules
\newcommand{\SecRule}[1][\medskipamount]{\par                       
\vspace*{\dimexpr-\parskip-\baselineskip+#1}
\noindent\rule{\columnwidth}{0.4mm}\par                             
\vspace*{\dimexpr-\parskip-.5\baselineskip+#1}}

\setbeforesecskip{-12mm}
\setaftersecskip {-1sp} 
\setsecnumformat{\csname  the#1\endcsname\par\nobreak\vspace{-0.1cm} 
\SecRule \par\nobreak } 

\newcommand{\ruledsec}[1]{
\fontsize{13pt}{12pt} \bfseries \centering \MakeUppercase{#1} \par 
\vspace{0.2cm} 
}
\setsecheadstyle{\ruledsec}

\begin{document}
\section{Test}
\lipsum[1]
\lipsum[1]
\end{document}

result

Following the replies to these topics did not help First paragraph of section becomes indented after setting \setbeforesecskip (memoir class) First paragraph indented after section title in margin

  • Thanks @cfr but it's the opposite: text should not be indented after a section heading, the first line should start where the other start with no extra space. – peppino Aug 26 '17 at 9:13
  • Oops. Sorry. Misread your question. – cfr Aug 26 '17 at 13:40
0

Solved by adding a negative horizontal space![enter image description here1

\newcommand{\ruledsec}[1]{
\fontsize{13pt}{12pt} \bfseries \centering \MakeUppercase{#1} \par
\vspace{0.2cm} 
\hspace{-0.15cm} 
\noindent
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.