2

Forum,

When I add a table of contents in my LaTeX document, hyperlink it to the corresponding pages of the document and therefore bookmark it, the bookmarked sections written in the Cyrillic alphabet don't appear at the bookmarked section.

There is the code to demonstrate:

\documentclass{article}

\usepackage{cmap}
\usepackage[utf8]{inputenc}
\usepackage[T2A]{fontenc}
\usepackage{hyperref}
\hypersetup{colorlinks,citecolor=black,filecolor=black,
linkcolor=black,urlcolor=black}

\makeatletter
\newcommand*{\toccontents}{\@starttoc{toc}}
\makeatother

\begin{document}

\toccontents

\section{Аааа}

\section{Бббб}

\section{Вввв}

\section{Гггг}

\section{Дддд}

\section{Ееее}

\end{document}

This creates really beautiful document with nicely linked table of contents. Sadly, as we see below, the bookmarks are empty and this doesn't happen if the section are titled in Latin alphabet.

enter image description here

In my case we have Cyrillic sections and I cannot see them bookmarked. Can someone suggest a way to make them appear?

3

Add the unicode option either to \hypersetup or the \usepackage[unicode,...]{hyperref} in order to enable the unicode encoding for bookmarks etc.

\documentclass{article}

\usepackage{cmap}
\usepackage[utf8]{inputenc}
\usepackage[T2A]{fontenc}
\usepackage{hyperref}
\hypersetup{unicode,colorlinks,citecolor=black,filecolor=black,
linkcolor=black,urlcolor=black}

\makeatletter
\newcommand*{\toccontents}{\@starttoc{toc}}
\makeatother

\begin{document}

\toccontents

\section{Аааа}

\section{Бббб}

\section{Вввв}

\section{Гггг}

\section{Дддд}

\section{Ееее}

\end{document}

enter image description here

  • 1
    Have my best regards, it works. – ecclesiastes Aug 28 '17 at 22:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.