2

I've noticed that using the option \usepackage[para]{footmisc} slightly increases the amount of space between the footnote mark and the footnote text. Here's a MWE with which to creat the effect.

\documentclass{article}
\usepackage[para]{footmisc}
\begin{document}
Text\footnote{A footnote.}
\end{document}

Without footmisc, I get this: Without footmisc

With footmisc, I get this: With footmisc

Note that I'm not at all worried about the change in the margin. What I don't like is the larger space between the 1 and the letter A.

Is there a command to fix this? Various footmisc options didn't seem to work and, though adding \hskip-0.25em to the footnote text seemed to help, it's not an ideal solution...

  • It seems related to the para option. Is that option a requirement of yours? – Steven B. Segletes Sep 1 '17 at 10:51
  • @StevenB.Segletes Yes, it basically is. I'm writing a document that requires the references are displayed as footnotes so I want to use footmisc's para option. – Warrick Sep 1 '17 at 10:52
1

Here, I employ a fixed negative kern at the beginning of each footnote. I also note that the issue seems related to the para option of the footmisc package.

\documentclass{article}
\usepackage[para]{footmisc}
\usepackage{lipsum}
\let\svfootnote\footnote
\renewcommand\footnote[2][\relax]{\ifx\relax#1%
  \svfootnote{\kern-4.5pt#2}\else\svfootnote[#1]{\kern-4.5pt#2}\fi}
\begin{document}

Text\footnote{This}
Text\footnote{is}
Text\footnote{a}
Text\footnote{test}
Text\footnote{of}
Text\footnote{the}
Text\footnote{emergency}
Text\footnote{broadcast}
Text\footnote{system}
Text\footnote{\lipsum[1]}
\end{document}

enter image description here

1

From my investigations for Reduce the space between inline footnotes style=verbose-inote.

The space between footnote marker and footnote text is hard-coded in footmisc with the para option as 0.5em in

\long\def\@makefntext#1{\leavevmode
  \@makefnmark\nobreak
  \hskip.5em\relax#1%
}

To remove the space, just remove the \hskip.5em\relax from the definition. Of course you can just decrease the value if you want to keep some space. Don't forget the \makeatletter...\makeatother if you redefine the macro in the preamble.

\documentclass{article}
\usepackage[para]{footmisc}

\makeatletter
\long\def\@makefntext#1{\leavevmode
  \@makefnmark\nobreak
  #1%
}
\makeatother

\begin{document}
Lorem\footnote{lorem}
ipsum\footnote{ipsum}
dolor\footnote{dolor}
sit\footnote{sit}
\end{document}

No space between footnote marker and text.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.