I have the following code in my preamble:

\usepackage[nopostdot]{glossaries} \setglossarystyle{altlisthypergroup} \makenoidxglossaries \input{Tekst/Glossary}

and I get something like this:

glossary appearance

I would like to lose the "Symbols" index and have it replaced with number(s). Can anyone help?

  • Try \renewcommand{\glssymbolsgroupname}{number(s)} – Nicola Talbot Sep 2 '17 at 9:37
  • Can you also please tell me, how to add space under the hyper navigation bar? – vbobanac Sep 2 '17 at 10:25

The symbols group heading is given by \glssymbolsgroupname, so you can redefine this command as appropriate. The altlisthypergroup style uses \glslistnavigationitem to format the navigation bar (where the argument is the navigation list), so you can redefine this to add extra space. (If this command isn't defined, your version of glossaries is too old.)




\newglossaryentry{1streef}{name={1st reef},
  description={When the 1st reef...}}

  description={A heavy device...}}

\newglossaryentry{balancedhelm}{name={balance helm},
  description={When a boat...}}





image of document

(Aside: the \makenoidxglossaries method is very much a method of last resort. It uses TeX to sort, collate and determine the letter groups, so if you have a large number of entries it will slow the build process quite considerably. It has to work out the letter group for each top-level item in the glossary by examining the first token of the sort value and comparing it with the previous value to determine if a new group has started. If you're having difficulty with running the makeglossaries or makeglossaries-lite scripts, try \makeglossaries with the automake package option.)

  • Thank you for your answers and advices. Really helpful! I tried both option1 and option2 (with makeindex) from your documentation and they both work fine. Option1 is a bit slower but still tolerable for my cca. 70 entries. I do have one additional question though. What happened to me is that I got a page break right after the groupheading. So now I got letter J on one page and all the entries starting with j on the next page, which doesn't look very nice. I've been digging through your documentation and forums, but can't seem to work my way around it... – vbobanac Sep 2 '17 at 22:59
  • One more question, how can I increase spacing between entries (not between groups, I realize there is \glsgroupskip for that)? I understand that adding e.g. \medskip after glossary entries answers both of my questions, but I figure there's got to be a more elegant way to do this. – vbobanac Sep 3 '17 at 10:20
  • @vbobanac The altlisthypergroup style uses the description environment, so you may be able to adjust that, but it depends on the document class and any related packages. I recommend you modify the MWE in my answer so that it uses your document class (and any package that relates to the way lists are defined, if applicable) and post it as a separate question. (There's a related question Prevent glossary entries from separating title and description at page breaks which may help, but it uses the indexgroup style.) – Nicola Talbot Sep 3 '17 at 11:20
  • I managed to increase spacing by redefining lists. I am using memoir class with the option \tightlists turned on. I just put \firmlists before printing the Glossary and got exactly what I wanted. I didn't manage to prevent the page break, but it doesn't matter, I'll do it manually if necessary. Thank you! – vbobanac Sep 4 '17 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.