2

I am trying to type a matrix, but the parentheses looks bigger. How can I make the parentheses fit?

It looks like the problem is caused by the doublespacing, but I want the double spacing for the text. How can I get around this?

Below is the code:

\documentclass{article}
\usepackage{amsmath}
\usepackage[doublespacing]{setspace}
\begin{document}
\begin{equation}
\rho=
\begin{pmatrix}
\rho_{00} & \rho_{01}\\
\rho_{10} & \rho_{11}
\end{pmatrix}
\end{equation}

\end{document}

Here is the image: enter image description here

8
  • Hi, welcome. A complete (yet minimal) example might be useful, it doesn't look like that in \documentclass{article} \usepackage{amsmath} \begin{document} \begin{equation} \rho= \begin{pmatrix} \rho_{00} & \rho_{01}\\ \rho_{10} & \rho_{11} \end{pmatrix} \end{equation} \end{document}. – Torbjørn T. Sep 6 '17 at 2:40
  • Hi, thanks for the reply. I do use amsmath package but use a customed class and style. I am not sure which could affect this or how I can override this. Could it possible because the use of setspace package? If needed, I can attach the .sty file – Bin Fang Sep 6 '17 at 3:36
  • 1
    Questions seeking debugging help ("why isn't this code working?") must include the desired behavior, a specific problem or error and the shortest code necessary to reproduce it in the question itself. Questions without a clear problem statement are not useful to other readers. See minimal working example (MWE). – Henri Menke Sep 6 '17 at 3:54
  • Since you haven't even told us which "customised class and style" you are using, do you expect people to read your mind to find out? Unless you provide a complete and runnable small example that shows the problem, nobody can help you fix it! – alephzero Sep 6 '17 at 4:57
  • 1
    Whatever else you do, be sure to specify the option nodisplayskipstretch when loading the setspace package. – Mico Sep 7 '17 at 18:17
0

Mentioned problem doesnot happen if we use the standard tagging, e.g.,

\documentclass{article}
\usepackage{amsmath}
\begin{document}

\begin{equation}
\rho=
\begin{pmatrix}
\rho_{00} & \rho_{01}\\
\rho_{10} & \rho_{11}
\end{pmatrix}
\end{equation}

\end{document}

So the problem might be related with your customized class file, also if we use the package with double spacing option like "\usepackage[doublespacing]{setspace}" as suggested by one of a great egreg then the same problem happened with this code also, so better check and remove the setspace package from your class file and try...

2
  • Remove doublespacing will address the problem but how can I get around this if I need doublespacing for the text. Thanks. – Bin Fang Sep 7 '17 at 18:03
  • If you want to increase the leading space alone then use the tag \addtolength{\baselineskip}{3pt} and if you want to increase both fontsize and leading then use the tag as \fontsize{13}{17}\selectfont at the preamble part – MadyYuvi Sep 8 '17 at 5:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.