2

I'm using LaTeXTools for Sublime Text 3, and trying to use the minted package. I get the following error:

Package minted Error: You must invoke LaTeX with the -shell-escape flag. [\usepackage]

How do I "invoke LaTeX" with flags when using laTeXTools? There is a similar question with an answer here: How to invoke latex with the -shell-escape flag in TeXMakerX?

But that answer is for TeXstudio. And I don't know how that translates to Sublime Text 3 on Windows 10

  • 2
    According to the documentation of LaTeXTools this can be done by editing the settings file. – leandriis Sep 6 '17 at 10:23
  • 1
    @leandriis Can you make an answer from your comment. IMHO, it could be useful to have an answer, that describes what to change and how. – Schweinebacke Sep 6 '17 at 10:30
2

From the first comment above, you can add flags to the LaTeXTools user settings. Specifically, you need to configure the builder. To do this

1. Go to preferences,
2. Go packages settings
3. Choose LaTeXTools
4. Go to user settings
5. Add the options tuple to "builder_settings"


"builder_settings" : {
    "options": ["--shell-escape"],
     ....
 }

You can find more information here: https://latextools.readthedocs.io/en/latest/settings/#builder-settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.