0

when I cite the items on the bibliography, I get the page numbers where citation happen appear after the bibliography. For eg: in the image, the number "3" at the end is the page number where this bib item is cited. I don't want this happening.

MWE

\documentclass[a4paper,11pt,twoside]{report}

\usepackage{thesis}
\usepackage{epstopdf}
\usepackage{amsfonts}

\begin{document}

\pagenumbering{arabic}
\include{titlepage}

\normalsize
\tableofcontents

\input{Introduction}
\input{SystemDescription}
\input{ControllerDesign}
\input{ObserverDesign}
\input{LinearController}
\input{Comparison}
\input{Conclusion}
\input{Recommendation}
\bibliographystyle{ieeetr}
\bibliography{bibliography.bib}

\end{document}

enter image description here

  • 1
    Please add a MWE to your question. Without knowing the code you have used it is nearly impossible to give you an appropriate answer. A helpfull hint may nevertheless be, that this behaviour might occure due to an option or package related to so called backreferencing. – leandriis Sep 6 '17 at 13:59
1

Since the OP does not provide a compilable MWE, it is difficult to troubleshoot the issue. However, the behaviour of back-referencing is usually related to hyperref package, with the extension option for back-referencing invoked, e.g. backref=true and pagebackref=true.

Setting such options to backref=false and pagebackref=false helps disabling back-referencing. For further information, see hyperref manual http://www.tug.org/applications/hyperref/manual.html

  • Where am I supposed to look for backref? I don't find it any of the files. – Joseph Benny Sep 6 '17 at 14:06
  • How am I, then, supposed to know when you do not provide an MWE? – M. Ridha Siregar Sep 6 '17 at 14:09
  • Look for \usepackage{hyperref} \hypersetup{backref=true, pagebackref=true} or something like that. It is guessing, again. – M. Ridha Siregar Sep 6 '17 at 14:14
  • I found it. pagebackref=true was the problem. Thanks! – Joseph Benny Sep 6 '17 at 14:20
  • You're welcome. Glad that it helps. – M. Ridha Siregar Sep 6 '17 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.