6

I am using acmart package manuscript option to write a report not intended to submit to ACM, yet It seems it insists on the output of "Manuscript submitted to ACM", is there any way I can remove it? TIA

\documentclass[review=true, screen, anonymous]{acmart}
\settopmatter{printacmref=false} % Removes citation information below abstract
\renewcommand\footnotetextcopyrightpermission[1]{} % removes footnote with conference info
\setcopyright{none}
\pagestyle{plain} % remove running headers
\title{TBD}
\author{}
\begin{document}
\maketitle
\end{document}
8

The acmart class has the text Manuscript submitted to ACM explicitly hard-coded in standardpagestyle and firstpagestyle, so either one has to redefine those pagestyles (this will be tedious!) or applies a small patch with \ps@firstpagestyle etc., substituting the undesired text with empty space, which is done by \xpatchcmd and leaving the replacement 'slot' {} empty (see below)

In addition, if the document class option manuscript is set, the boolean 'variable' \@ACM@manuscript is set to true, so this should be set to false explicitly.

Small info: page styles are defined in a macro name \ps@X, where X stands for the name of the page style, i.e. plain or firstpagestyle.

Since @ macros are involved, a \makeatletter...\makeatother pair is needed.

\documentclass[review=true, screen, anonymous,manuscript]{acmart}

\usepackage{blindtext}

\usepackage{xpatch}

\makeatletter
\xpatchcmd{\ps@firstpagestyle}{Manuscript submitted to ACM}{}{\typeout{First patch succeeded}}{\typeout{first patch failed}}
\xpatchcmd{\ps@standardpagestyle}{Manuscript submitted to ACM}{}{\typeout{Second patch succeeded}}{\typeout{Second patch failed}}    \@ACM@manuscriptfalse% Also in titlepage
\makeatother

\settopmatter{printacmref=false} % Removes citation information below abstract
\renewcommand\footnotetextcopyrightpermission[1]{} % removes footnote with conference info
\setcopyright{none}
\pagestyle{plain} % remove running headers
\title{TBD}
\author{}
\begin{document}
\maketitle

\blindtext[20]
\end{document}

enter image description here

6

Just ran into this problem with the new ACM template and tried (unsuccessfully) a number of possible solutions. Then ran across this solution while carefully reading the class documentation.

Pass the nonacm option to the \documentclass command. See Table 2 in the acmart class documentation.

Example:

\documentclass[manuscript,screen,timestamp,authordraft,nonacm]{acmart}
                                                       ^^^^^^
1
  • Only this works for me! Thanks
    – Simon
    Jan 5 '21 at 13:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.