1

I understand this question has been asked multiple times but I am not able to get an appropriate solution for my problem. If I remove the bibliography, the program runs fine but on adding it, I get the error given below. What should I do to resolve it? Also, this error comes when I put the bibliography in Sage Vancouver style only.If I change to Sage Harvard style, the error vanishes. But I need bibliography in Sage-Vancouver style only

Error

Overfull \vbox (2.93578pt too high) has occurred while \output is active []
Package natbib Error: Bibliography not compatible with author-year citations. ...mand\NAT@force@numbers{}\NAT@force@numbers

Latex program:

% sage_latex_guidelines.tex V1.10, 24 June 2016

\documentclass[Afour,sageh,times]{sagej}

\usepackage{moreverb,url}

\usepackage[colorlinks,bookmarksopen,bookmarksnumbered,citecolor=red,urlcolor=red]{hyperref}

\newcommand\BibTeX{{\rmfamily B\kern-.05em \textsc{i\kern-.025em b}\kern-.08em
T\kern-.1667em\lower.7ex\hbox{E}\kern-.125emX}}

\def\volumeyear{2016}

\begin{document}

\runninghead{Smith and Wittkopf}

%\title{A demonstration of the \LaTeXe\ class file for
%\itshape{SAGE Publications}}
\title{ABCXYZ}
\author{Al \affilnum{1} and HenD\affilnum{2}}

\affiliation{\affilnum{1}Sunrise Setting Ltd, UK\\
\affilnum{2}SAGE Publications Ltd, UK}

\corrauth{XUZABC}


\begin{abstract}

\end{abstract}

\keywords{abc, def, hja }

\maketitle

\section{Introduction}


\subsection{References}


\begin{acks}
This class file was developed by Sunrise Setting Ltd,
Brixham, Devon, UK.\\
Website: \url{http://www.sunrise-setting.co.uk}
\end{acks}


\begin{thebibliography}{99}

    \bibitem[1]{R1}
    2. Sikander A, Prasad R. Soft Computing Approach for Model Order Reduction of Linear Time Invariant Systems. \textit{Circuits, Systems, and Signal Processing}. 2015;34(11):3471-3487.

    \bibitem[2]{R2}
    Smamash, Y. (1981). Truncation method of reduction: a viable alternative. Electronics Letters, 17(2), p.97.


\end{thebibliography}

\end{document}


\end{document}
2

The sagej document class loads the natbib citation management package.

Almost certainly, the journal's expected work flow is that authors use BibTeX, so that the contents of the thebibliography environment are produced by software, using a bibliography style that's compatible with natbib. (Fortunately, lots of bibliography styles are compatible with natbib.)

However, it looks like you are building the bibliography by hand. If that's the case, you must not only provide the formatting of the bibliographic items, you must also assure that the contents of the optional argument of \bibitem -- the material that's enclosed by square brackets -- satisfies natbib's expectations. As you can guess by now,

\bibitem[1]{R1} ...
\bibitem[2]{R2} ...

does not satisfy these expectations. Instead, you should write

\bibitem[Sikander and Prasad(2015)]{R1}  ...
\bibitem[Smamash(1981)]{R2} ...

(Observe: no space between the name and the year in parentheses.)

It looks like you prefer to generate numeric citation call-outs rather than authoryear-style citation call-outs. To achieve this objective, simply provide the instruction

\setcitestyle{numbers}

in the preamble. If, at some point in the future, you decide to change over to authoryear-style citation call-outs, all you'll have to do is change the preceding directive to \setcitestyle{authoryear}.

In the medium to long run, though, you may want to look into learning how to use BibTeX (or some other tool, such as biblatex), to generate a formatted bibliography along with appropriately formed citation call-outs. You'll be amazed how much time you'll save yourself, compared with the slow and error-prone process of building the bibliography and the citation call-outs entirely by hand.


A full MWE:

\documentclass[Afour,sageh,times]{sagej}

\setcitestyle{numbers} % <--- this is new

\usepackage{moreverb,url}

\usepackage[colorlinks,bookmarksopen,bookmarksnumbered,
    citecolor=red,urlcolor=red]{hyperref}

\newcommand\BibTeX{{\rmfamily B\kern-.05em \textsc{i\kern-.025em b}\kern-.08em
T\kern-.1667em\lower.7ex\hbox{E}\kern-.125emX}}

\def\volumeyear{2016}

\begin{document}

\runninghead{Smith and Wittkopf}

%\title{A demonstration of the \LaTeXe\ class file for
%\itshape{SAGE Publications}}
\title{ABCXYZ}
\author{Al \affilnum{1} and HenD\affilnum{2}}
\affiliation{\affilnum{1}Sunrise Setting Ltd, UK\\
\affilnum{2}SAGE Publications Ltd, UK}
\corrauth{XUZABC}

\begin{abstract}
\end{abstract}
\keywords{abc, def, hja }

\maketitle

\cite{R1}, \cite{R2}

\begin{thebibliography}{99}

\bibitem[Sikander and Prasad(2015)]{R1}
    Sikander A, Prasad R. (2015). Soft Computing Approach 
    for Model Order Reduction of Linear Time Invariant 
    Systems. \textit{Circuits, Systems, and Signal 
    Processing}. 2015;34(11):3471--3487.

\bibitem[Smamash(1981)]{R2}
    Smamash, Y. (1981). Truncation method of reduction: A 
    viable alternative. Electronics Letters, 17(2), p.~97.

\end{thebibliography}
\end{document}
1

For author-year citations, we need to tag the bibliography entry as in the correct which was described in natbib package documentation. Please refer the below tag:

\documentclass{book}

\usepackage{moreverb,url}

\usepackage[authoryear]{natbib}
\usepackage[colorlinks,bookmarksopen,bookmarksnumbered,citecolor=red,urlcolor=red]{hyperref}

\newcommand\BibTeX{{\rmfamily B\kern-.05em \textsc{i\kern-.025em b}\kern-.08em
T\kern-.1667em\lower.7ex\hbox{E}\kern-.125emX}}

\begin{document}

%\title{A demonstration of the \LaTeXe\ class file for
%\itshape{SAGE Publications}}
\title{ABCXYZ}

\maketitle

\section{Introduction}


\subsection{References}



\begin{thebibliography}{}

\bibitem[\protect\citeauthoryear{Sikander, Prasad}{2015}]{R1}
    2. Sikander A, Prasad R. Soft Computing Approach for Model Order Reduction of Linear Time Invariant Systems. \textit{Circuits, Systems, and Signal Processing}. 2015;34(11):3471-3487.

    \bibitem[\protect\citeauthoryear{Smamash}{1981}]{R2}
    Smamash, Y. (1981). Truncation method of reduction: a viable alternative. Electronics Letters, 17(2), p.97.


\end{thebibliography}

\end{document}

I am using standard book class file and you are using the customized template sagej, please follow it and confirm still the error exists.

  • I agree. The style which both the answers have used above is Sage Harvard style and runs correctly. But the journal "Measurement and control" specifically instructs to use Sage Vancouver style which has numbers like [1] instead of author and year – ShiS Sep 8 '17 at 10:25
  • @Shivam Can you show a sample page (as an image) for your requirement? – MadyYuvi Sep 8 '17 at 10:26
  • I have understood where the problem lies. The problem is that natbib does not accept numbers but the Journal has specifically instructed to use numbers. I think I would try to use BibTeX for references and let it be generated via program. That would be the best case scenario. Thanks Mico and MadYuvy for the help. – ShiS Sep 8 '17 at 10:34
  • Is there an advantage to writing \protect\citeauthoryear{Smamash}{1981} instead of Snamash(1981)? – Mico Sep 8 '17 at 10:47
  • I am not sure, but I am following this method from the days when I start to use the package "natbib", for detailed explanation, please refer the package documentation, 8th page number...Thanks – MadyYuvi Sep 8 '17 at 11:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.