2

I am trying to use ConTeXt modes to prepare some text on two displays: screen and print.

\enablemode[screen]
\startmode[screen]
\setuppapersize[S6][S6]
\setuppagenumbering[state=stop]
\definefontfeature[default][default][onum=yes]
\definefontfamily[biolinum][sans][Linux Biolinum O]
\setuptolerance[verytolerant,stretch] 
\setupbodyfont[biolinum,20pt]%[features=onum]
\stopmode[screen]

\startnotmode[screen]
   \setuppapersize[A4][A4]
   \setuppagenumbering[state=start]
   \setupcolors[state=stop]
   \setupbodyfont[biolinum,12pt]
   \setuptolerance[strict]
\stopnotmode[screen]


\starttext

Here's my first presentation in \CONTEXT!

\stoptext

When I compile my MWE, I have an unwanted output [screen].

enter image description here

I read carefully ConTeXt reference manual and search the web, but cannot figure why is my output wrong. I tried to introduce several times \enablemode[screen] but it didn't change the output at all. I'm pretty sure I didn't understand something when reading the man and the wiki.

  • I am not sure which wiki page were you reading, but this is explained in detail on the page on modes – Aditya Sep 11 '17 at 17:23
  • Oh, I read several of them (modes, presentation, handout and so on), but those stop errors were too obvious to be noticed. Shame on me. – sztruks Sep 11 '17 at 19:01
5

The two environments to include and exclude commands with modes have the form

\startmode[...]
  ...
\stopmode

and

\startnotmode[...]
  ...
\stopnotmode

where only the start-command takes a argument with the name of the mode but not the stop-command.

  • Indeed, the same is true of all (?) ConTeXt's start-stop commands: the start might (often does) accept some options, but the stop doesn't. It's a bit like XML tags in that way. – 9tTn9B Sep 10 '17 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.