2

I am trying to use biblatex for the first time and running into problems. I looked up a lot of documentation, and here is what I have come up with so far. Here is my report document:

\documentclass[12pt]{article}
\usepackage[margin=1in]{geometry}
\usepackage{graphicx,color,float,amssymb,amsmath}
\usepackage{pdfpages}
\usepackage{wrapfig}
\usepackage[font=small]{caption, subcaption}
\usepackage[style=numeric]{biblatex}
\addbibresource{spec.bib}
\begin{document}

random text let's cite \cite{spec}
\printbibliography

and here is my bibliography document spec.bib:

\begin{filecontents}{spec.bib}


@manual{spec,

    title =        {Instruction Manual and Experimental Guide for the PASCO Scientific Model SP-9268A, Student Spectrometer}. ,
    date =      {January 1991},
    OPTlanguage = {English},
    OPTorganization = {PASCO Scientific}
    OPTpagetotal = {10}}

When I try to cite this in my document, I am getting the following error and no output for my references:

This is BibTeX, Version 0.99d (TeX Live 2017)
The top-level auxiliary file: Spectroscopy.aux
I found no \citation commands---while reading file Spectroscopy.aux
I found no \bibdata command---while reading file Spectroscopy.aux
I found no \bibstyle command---while reading file Spectroscopy.aux
(There were 3 error messages)

Not too what to do to fix this. Any advice will be helpful, thank you!

5
  • 2
    You are running BIbTeX, but with your set-up you need to run Biber. See Biblatex with Biber: Configuring my editor to avoid undefined citations for help on how to make your editor run Biber instead of BibTeX for you. See Question mark or bold citation key instead of citation number for background info on what Biber and BibTeX do.
    – moewe
    Sep 10, 2017 at 17:18
  • 1
    Please note that date = {January 1991}, is incorrect. date-like fields must be filled in YYYY-MM-DD format (EDTF), so you'd have to write date = {1991-01},. You also have a spurious . after the title = {...} before the comma. It should be title = {Instruction Manual and Experimental Guide for the PASCO Scientific Model SP-9268A, Student Spectrometer},
    – moewe
    Sep 10, 2017 at 17:20
  • So according to the link about biber, the only thing I saw I needed to add was the [backend=biber]? Getting the same error. Sep 10, 2017 at 17:31
  • No, that is definitely not the only thing you need to do (and in fact backend=biber is not necessary since it is the default, but I still like to include it nonetheless). If you use an editor, read up in Biblatex with Biber: Configuring my editor to avoid undefined citations what to do - it depends on your editor. If you compile manually, don't call bibtex <filename>, but biber <filename>.
    – moewe
    Sep 10, 2017 at 17:33
  • The file spec.bib should not have \begin{filecontents}{spec.bib}. This is only to store the references in the main .tex and sould hava a end (is not here). Consider use a program as JabRef. This help to make a .bib file without syntactic errors (among many others advantages).
    – Fran
    Sep 10, 2017 at 18:03

1 Answer 1

2

As a quick workaround (but that is only to get you started!) you can add the option backend=bibtex to package biblatex. Then BibTeX is used to create the bibliography ...

Now you can correct your errors in the code. In the bib file you have a . after the title you should delete and some missing commas. I corrected that in the following MWE.

I commented the packages not needed for your bibliography problem and added the missing \end{document}. The resulting code is mwe.tex, containing your bib file with package filecontents:

\RequirePackage{filecontents}
\begin{filecontents}{\jobname.bib}
@manual{spec,
  title = {Instruction Manual and Experimental Guide for the PASCO 
           Scientific Model SP-9268A, Student Spectrometer},
  date  = {1991-01},
  OPTlanguage     = {English},
  OPTorganization = {PASCO Scientific},
  OPTpagetotal    = {10},
}
\end{filecontents}


\documentclass[12pt]{article}

\usepackage[margin=1in]{geometry}
%\usepackage{graphicx,color,float,amssymb,amsmath}
%\usepackage{pdfpages}
%\usepackage{wrapfig}
%\usepackage[font=small]{caption, subcaption}
\usepackage[%
  style=numeric,
  backend=biber % biber bibtex <========================================
]{biblatex}
\addbibresource{\jobname.bib} % <===== to use the bib file created by filecontents

\begin{document}
random text let's cite \cite{spec}
\printbibliography
\end{document}

That will give you the result

enter image description here

after compiling with the chain

pdflatex mwe.tex
biber mwe       or: bibtex mwe
pdflatex mwe.tex
pdflatex mwe.tex

Change backend=biber to backend=bibtex to advice biblatex to use the backend you want to use.

Please follow the links given by user @moeve to learn how to configure your used editor to use biber instead of bibtex (recommended!).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.