0

I am trying to use TikZ library in LaTeXiT, but can't find a way to install TikZ. Below is a screenshot from LaTeXiT.

enter image description here

Installed MacTeX and then tried to configure LaTeXiT to use pdflatex from texlive. But now I am getting more issues: i.imgur.com/lOYA4bG.png

enter image description here

  • image posting is blocked for new users (until you get above a certain rep, 50 I think) I added the image for you, welcome to the site! – David Carlisle Sep 15 '17 at 8:02
  • What exact kind of LaTeX do you already have installed in order to use LaTeXit? – daleif Sep 15 '17 at 8:03
  • That library is part of the spath3 package it appears (ctan.org/pkg/spath3?lang=en), so use the TeX Live Manager (assuming you have MacTeX installed) to install spath3. – Torbjørn T. Sep 15 '17 at 8:07
  • 1
    Bad idea, use MacTeX, We have had several Mac users users lately that have had issues messing up MacTeX, texlive from mac ports etc. It is not worth it. use MacTeX. It is complete and super easy to install. – daleif Sep 15 '17 at 8:27
  • 1
    I know nothing about LaTeXiT, but an error saying that \documentclass is undefined typically occurs if you use pdftex instead of pdflatex. – Torbjørn T. Sep 15 '17 at 13:10
1

I had to install MacTeX, which can be downloaded from http://www.tug.org/mactex/. Install all .pkg applications from Applications/TeX directory. It does contain LaTeXiT.

Overall on OSX, you just need MacTeX to get started.

enter image description here enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.