0

I'm having some problems with LaTex. I recently installed it to my computer, but do not have admin rights so did a local install to my user. I first installed MikTex, then installed TexMaker. I tried making a pdf from a .tex file I have saved from a scipt I made on my other computer. I got the following error: LaTex Error: File 'scrartcl.cls' no found. I looked into this and saw that this is from not having Koma-Script installed. So I went to https://www.ctan.org/pkg/koma-script?lang=en to download the .zip file an unzipped it. I looked the README and INSTALL files, which say "MiKTeX users can easily install the current release of KOMA-Script using the self extracting archive for windows also known as MiKTeX installation file. See http://www.komascript.de/current for more information. But if you want to install another release, you have to read the installation instructions below." I went to that page which led to https://komascript.de/node/2047. This page says to download a MD5 file that I then downloaded. I then opened MikTex Package Manager and found the Koma-script and tried to install it but got the error that "~/koma-script" is not a package repository. What am I doing wrong? I'm on Windows 10 if that affects anything

  • 1
    Why do you want to install manually instead of using the package manager of miktex? – Ulrike Fischer Sep 15 '17 at 12:08
  • I am using the package manager. Sorry, I will edit that. I meant manually install as in downloading the files then using the package manager as opposed to the package manager or TexMaker installing them from the web. – TheStrangeQuark Sep 15 '17 at 12:23
  • The zip-file is not a miktex package. You will need a file from here ctan.org/tex-archive/systems/win32/miktex/tm/packages if you want to install with the package manager. And you will need the two miktex-zz-files. – Ulrike Fischer Sep 15 '17 at 13:04
1

Create a local repository on your hard disk and download the files you're interested in, plus the following files: pr.ini, miktex-zzdb1-2.9.tar.lzma, miktex-zzdb2-2.9.tar.lzma and files.csv.lzma. Then launch MPM, menu Repository -> Change Package Repository… and select Packages shall be installed from a directory:

enter image description here]1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.