1

I am using IPE to make presentations on Ubuntu 16. I use i3 for my window manager (in case that is relevant).

I downloaded the AppImage v 7.2.7 today from the ipe website.

I start ipe with

./ipe-7.2.7-x86_64.AppImage ipe -sheet presentation

When editing complex LaTeX code, the default editor window size is way too small; everything is crammed in a tiny space. Of course, one can drag the edge of the editor window to make it larger and get more space. However, it becomes pretty painful to resize the window every single time you want to edit some large amount of LaTeX.

enter image description here

Possible Solution 1: Set the default size of the IPE LaTeX editor. Is this possible?

Possible Solution 2: Use external editor. I could not make it work.

I tried to set up external editing. In the terminal I run

export EDITOR=some_editor

and then when in IPE, I click the 'Editor' button.

I have tried vim, gedit, and sublime (my preferred TeX editor) and they all fail in different ways. Vim and gedit do not open, and IPE flashes 'waiting for editor' for a split second, and then takes me back to the built-in editor. For sublime (which I would really like to work), I get error dialogs coming from sublime, which I can't read (see image), I cannot read any characters in sublime (see image), and the Ipe editor remains open and in focus.

If I install ipe using apt-get (instead of using the AppImage), I am able to open sublime as an external editor, but when I enter my latex and then save the file and exit sublime, that text does not show up in the ipe document.

How to fix / diagnose this problem?

Ipe external editor with sublime

  • 1
    Did you try setting prefs.editor_size? – Marc Glisse Sep 18 '17 at 18:11
2

I was able to solve the problem of the editor size.

In my home directory in .ipe/ipelets/customize.lua I added the line

prefs.editor_size = { 1000, 600 }

Thanks, Marc Glisse for pointing out the solution.

I still was not able to launch the external editor correctly.

  • nice! Just accept your answer too. – koleygr Sep 19 '17 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.