0

I want to cite a book from Albert-László Barabási. In the text the format ('last name of author', 'year') should be used, but the citation is printed in the format ('first name' 'last name', 'year').

I found out that the behavior is related to the "acute accents" in his name. When the BibTeX entry is changed from author = {Barab\'{a}si, Albert-L\'{a}szl\'{o}} to author = {Barabasi, Albert-Laszlo} the citation has the correct format ('last name', 'year').

How can this behavior be changed to print the 'normal' format?

4
  • When I use author = {Barab\'{a}si, Albert-L\'{a}szl\'{o}} with \bibliographystyle{apalike}, I got a correct[Barabási, 2013] reference. -- What is the style you are using ?
    – Jaime
    Sep 16, 2017 at 15:32
  • I use the following setup: \usepackage[style=authoryear,backend=biber,bibencoding=auto]{biblatex}. Sep 16, 2017 at 15:47
  • 1
    Using Sharelatex, I got a correct Barabási, 2013. Please provide code for a MWE.
    – Jaime
    Sep 16, 2017 at 16:16
  • See also biblatex, authoryear style: In-text citations display first name initials for certain bibliography entries even though in this case the solution was not to turn off the disambiguation feature, but to fix a typo in the .bib source.
    – moewe
    Sep 17, 2017 at 10:00

1 Answer 1

0

I found the cause. It was a typo in second biblatex entry: author = {Newman, Mark and Barabási, Alberto-László} instead of author = {Newman, Mark and Barabási, Albert-László} (Alberto vs. Albert).

When both entries are cited the behavior occurs. Fixing the typo fixes the citations.

I guess the first name is written to distingues between two authors with the same last name.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .