1

I am working on a French document using the tufte-book class and I get errors related to the bibliography.

Here is a MWE:

\documentclass[french]{tufte-book}
\usepackage{babel}
\usepackage{babelbib}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}

\begin{document}
Example of a French sidenote reference \cite{example}.

\bibliography{references}
\bibliographystyle{babplain}

\end{document}

The content of references.bib is :

@techreport{example,
title = {Exemple d'un rapport technique avec un accent},
language = {french},
year = {2000},
author = {Tremblay, Jean},
pages = {1--10},
institution = {Institut de recherche du Québec}
}

I get the following error:

Undefined control sequence. l.2 \providebibliographyfont {name}{}%

The error doesn't occur if I comment the call to the babelbib package and change the bibliography style to plain. Nonetheless, this produces a sidenote refrence with improper encoding:

enter image description here

Plus I get the "Technical Report" label instead of "Rapport technique" (French).

2 Answers 2

1

You need to add the nobib option (on which the documentation is silent), which disables the loading of natbib (which in turn would disable babelbib).

\documentclass[french,nobib]{tufte-book}
\usepackage{babel}
\usepackage{babelbib}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}

\begin{document}
Example of a French sidenote reference \cite{example}.

\bibliographystyle{babplain}
\bibliography{references}

\end{document}

enter image description here

Why is “rapport technique“ lower case? It seems a problem in babelbib. You can fix it, though.

\documentclass[french,nobib]{tufte-book}
\usepackage{babel}
\usepackage{babelbib}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{xpatch}

\AtBeginDocument{%
  % \bibsfrench has 'rapport technique'
  \xpatchcmd{\bibsfrench}{rapport}{Rapport}{}{}%
}

\begin{document}
Example of a French sidenote reference \cite{example}.

\bibliographystyle{babplain}
\bibliography{references}

\end{document}

enter image description here

3
  • 1
    Unfortunately, this doesn't solve my problem because adding the "nobib" option results in no sidenote reference being printed... Sep 19, 2017 at 20:33
  • @cathenkayak Sorry, that's how far you can go, as the class needs bibentry which seems to depend on natbib. The tufte classes are badly written, in my opinion.
    – egreg
    Sep 19, 2017 at 20:34
  • @cathenkayak Actually, bibentry doesn't really depend on natbib, but apparently the way bibplain writes the .bbl file conflicts with bibentry.
    – egreg
    Sep 19, 2017 at 21:05
0

You can use the \bibliographystyle{plain-fr} without use add the nobib option. It's seems to work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .