0

I have a list of acronyms that it is working well, but suddenly after the chapter 3 acronym \ac{acl}[ACL]{Access Control List} it breaks. All acronyms after it appears as @<>@<>@acl (ACL). I am using sharelatex.com. The main log output doesn't show any error about acronyms. I am not using acronyms on footnotes. Which log can I see more details? How can I fix this?

Thanks

Edit I included \usepackage[acronym,nomain]{glossaries} and all the acronyms worked. But now my acronym list disappeared. I am using this to set the list of acronyms:

\input{acronyms}
\listofacronyms
\printglossaries

And the list of acronyms I am building like this:

\begin{acronym}[ACRONYM]
\newacronym{acl}{ACL}{Access Control List}
\newacronym{afm}{AFM}{Alphabet Frequency Matrix}
\end{acronym}

And I am using \gls{acl} to show the acronym.

  • If that acronym worked before chapter 3, there probably is an error unrelated to the actual acronym introduced in chapter 3, like missing brackets or such. I don't use sharelatex, so I can't help you with the location of the log files. Could you post a MWE so we can see what is going on? – Andreas Sep 20 '17 at 10:51
  • And if you wonder what a MWE is, look here. – Harald Hanche-Olsen Sep 20 '17 at 11:24
  • You seem to be mixing the acronym and glossaries packages code. \begin{acronym} is provided by acronym.sty but not by glossaries.sty. – Nicola Talbot Sep 20 '17 at 12:51
  • @felipe You'll need to build the glossary first -- either using \makenoidxglossaries or \makeglossaries (depends on how the index is constructed -- see the manual of glossaries!) in the preamble. – Andreas Sep 20 '17 at 12:51
  • thanks, I got using \printglossary[type=\acronymtype] – Felipe Sep 20 '17 at 13:07
1

I don't know why, but \newacronym{acl}{ACL}{Access Control List} breaks the function. If you rename it to something else like \newacronym{accesscl}{ACL}{Access Control List}, it should work. I think it's because acl does not work, because there is also the command \acl and the package has some trouble with it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.