0

When I start texmaker on the Linux commandline, this happens immediatly:

$ texmaker 
texmaker: symbol lookup error: texmaker: undefined symbol: synctex_next_result

Similarly, when enabling SyncTex in the gummi editor when it's already running and then trying to build a document:

$ gummi
[Info] ...
gummi: symbol lookup error: gummi: undefined symbol: synctex_next_result

Using SyncTex in Gummi only stopped working a few days ago. Changing to a different engine doesn't solve the problem. I'm using the TeX Live 2018/dev/Debian installed via apt on Linux Mint 18. How can I fix this issue?

  • 1
    Welcome to TeX.SX! Which Linux distribution and version of Texmaker and Gummi are you using? Did you install TeX Live using the package manager of your distribution or manually, and which version? – diabonas Sep 20 '17 at 12:03
  • Gummi is the up-to-date version (just says gummi git in the version information). Texlive is TeX Live 2018/dev/Debian. – Felix Rindt Sep 20 '17 at 19:12
  • 1
    I'm not sure we're going to be much help if Debian have got hold of a time machine and are bringing you back software from the future. Perhaps they'd care to share? Would save a lot of bother next year getting everything together. – cfr Sep 21 '17 at 1:08
  • The version number of TeX Live is strange indeed, the official Linux Mint repository currently includes TeX Live 2015. Is that really correct, and if so, from which repository did you get it? Anyway, I suspect the problem is a broken/incompatible version of libsynctex1 - try reinstalling it using apt-get install --reinstall libsynctex1. If that doesn't help, what is the output of ldd $(which gummi) | grep synctex? – diabonas Sep 21 '17 at 15:33
  • Reinstalling didn't help. ldd $(which gummi) | grep synctex yielded libsynctex.so.1 => /usr/lib/x86_64-linux-gnu/libsynctex.so.1 (0x00007f900e4b2000) – Felix Rindt Sep 22 '17 at 8:19
1

As I installed packages using a PPA, my synctex was too new for the rest of my texlive distribution. I solved by reinstalling texlive using the default ubuntu packages.

0

it is the same for me, i was try to reconfigure texmaker package and re-install it, but they not run, it is the problem, it is because a bug

" The latest update of libsynctex1 broke the ABI "

you can read about

https://groups.google.com/forum/?_escaped_fragment_=topic/linux.debian.bugs.dist/6XNBKiiV_jw#!topic/linux.debian.bugs.dist/6XNBKiiV_jw

https://groups.google.com/forum/?_escaped_fragment_=msg/linux.debian.bugs.dist/6XNBKiiV_jw/xW8MvAskAAAJ#!msg/linux.debian.bugs.dist/6XNBKiiV_jw/xW8MvAskAAAJ

0

For debian distribution and based in debian:

you need to dowmgrade to old stable version of libsynctex1 and Texmaker run fine again,

package manager: aptitude

texmaker depend of libsynctex1 (any version)

texmaker: 5.0.2-1+b1

[DOWNGRADE] libsynctex1: 2018.20180416.47457-1 -> 2014.20140926.35254-6

0

Downgrade libsynctex1. i did it with aptitude.

sudo apt install aptitude
aptitude versions libsynctex1
sudo aptitude install libsynctex1=2015.20160222.37495-1 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.