4

I used to use Esc to complete citations and references when typing in LaTeX using TeXShop but it doesn't work any more.

It stopped working on my new laptop probably because I had to install TeXShop from scratch, maybe losing some old configuration settings. I have read many posts about autocompletions (old and new) and tried some of the solutions. Unfortunately nothing has worked so far.

3
  • Welcome to TeX.SX! Which version of TeXShop are you using?
    – diabonas
    Commented Sep 20, 2017 at 12:54
  • 2
    This is a change that occurred relatively recently. There is no solution that I am aware of except to use F5 instead of ESC for bib completion.
    – Alan Munn
    Commented Sep 20, 2017 at 12:55
  • Not sure if this would be helpful to the OP, but on the latest editions of MacBook Pro that come with Touch Bar, cmd+esc works for autocompleting citations on Texshop with BibDesk open in the background. Commented Jun 6, 2020 at 8:52

1 Answer 1

3

Your observation is correct, ESC did used to be able to be used for bib completion as well as regular auto-completion. From what I can gather this was accidental and not by design, and F5 was supposed to be the command for bib completion.

So the only workaround is to get used to using F5 for bib completion instead of ESC (annoying, I know.)

One thing that might be helpful if you're using a laptop is the System Preference -> Keyboard to make the function keys behave as function keys without having to press the 'fn' key too. Selecting this preference flips the behaviour of the function keys so that you need to press the 'fn' key to get the special functions (volume, screen dimming etc.). Personally I use the special keys more than the function keys so I don't set this option, but it's useful to know that it exists even to turn it on temporarily.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .