0

I have a letter which, visually and practically, will look nicer if all content, including the closing section (closing sentence + small image of a signature + name), is kept in page 1. The content, as seen in the following screenshots, is not much.

The letter is based on the following files:

(which are based on the files at invoice_el/tree/master/sources)

Update

As per one of the comments, the settings for the geometry package are overwritten by the KOMA option DIV=last. Even if so, perhaps the design of the page without the geometry options might be "ok" (as can be seen with \usepackage[showframe]{geometry}. To practically address the problem, the question can be: how can only the vertical size of the letter page be increased, so the closing and signature and name appear on page one?

Screenshots

Here is page 1

and here is page 2

Perhaps it is the (non-visible) footer that makes things hard to keep in one page? I have tried a couple of things to work this around (including suggestions from https://tex.stackexchange.com/a/4472/8272) without success.

How can I force the closing section to stay in page 1 like in the following smudged one page sample?

  • How about \enlargethispage{\baselineskip} or even \enlargethispage*{\baselineskip} (which tries to squeeze the text on the page together) before \close{…}? You could try different sizes instead of the \baselineskip. – Andreas Sep 20 '17 at 16:53
  • The closing is a quite large block (at least one line of text, greeting, signature) and so it has a tendency to lead to an overfull page and then it goes to the next page. \enlargethispage{..} as suggested by Andreas is normally the way to go. Or reduce the spacing in the text. – Ulrike Fischer Sep 20 '17 at 17:32
  • Sorry, but your settings in the linked code are a mess. E.g. package geometry is loaded but later on DIV=last is used. So every settings by \geometry will be overwritten. – esdd Sep 20 '17 at 19:00
  • Suggestion: With an uptodate KOMA-Script version you could use \KOMAoptions{usegeometry} before loading geometry. Then replace your \geometry settings by \geometry{verbose,bmargin=1.5cm,includefoot} and remove the later DIV=last in the argument of \KOMAoptions (in custom_invoice_template_el.tex). And maybe you want to change \@addtoplength[-]{firstfootvpos}{\useplength{toaddrvpos}} to \@addtoplength[-1.2]{firstfootvpos}{\useplength{toaddrvpos}}% in the lco file. – esdd Sep 20 '17 at 19:10
  • 1
    Add usegeometry to the class options (and remove \KOMAoptions{usegeometry} from custom_invoice_template_el.tex. – esdd Sep 21 '17 at 9:15
2

Unfortunaly there is no MWE in the question and the linked code is a mess. So I will use a different example.

Since KOMA-Script version 3.17 there is an option usegeometry. If this option is set, package typearea tries to translate all of its options into options of package geometry.

So you can add usegeometry to the class options. Then you can load geometry and change the bottom margin.

\documentclass[
  usegeometry
]{scrlttr2}

\usepackage{geometry}
\geometry{bottom=1.5cm,includefoot}

%\usepackage{showframe}% to show the page layout
\usepackage{lipsum}% only for dummy text

\begin{document}
\begin{letter}{toaddress}
\opening{Hello,}
\lipsum

\end{letter}
\end{document}
  • Thanks, I did eventually get what I needed regarding the visual output. I will ask a separate question on how to improve the custom template. – Nikos Alexandris Sep 27 '17 at 6:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.