2

I am using empheq along with subequations as given in the MWE. However, the use of subequations create a vertical space between the paragraph and equation as shown in figure, which I don't want. I already tried answers available in [1,2]. Both the answers are not available to remove the space. Implementation of these answers provided in MWE 1 and 2, respectively.

enter image description here

MWE

\documentclass[a4paper,twoside,12pt]{report}
\usepackage{lipsum}
\usepackage[overload]{empheq}

\begin{document}
\lipsum
\begin{subequations}
    \begin{empheq}[left={H=\empheqlbrace\,}]{align}
        & 2 G_{0} - 2.6 \quad \forall \quad G_{0}~<~100~K \\
        & 2 G_{0} - 9.8 \quad \forall \quad G_{0}~>~100~K  
    \end{empheq}
    \label{eq:k_temperature_correlation}
\end{subequations}
\lipsum
\end{document}

MWE 1

\documentclass[a4paper,twoside,12pt]{report}
\usepackage{lipsum}
\usepackage[overload]{empheq}
\usepackage{etoolbox}
\preto\subequations{\ifhmode\unskip\fi}

\begin{document}
\lipsum
\begin{subequations}
    \begin{empheq}[left={H=\empheqlbrace\,}]{align}
        & 2 G_{0} - 2.6 \quad \forall \quad G_{0}~<~100~K \\
        & 2 G_{0} - 9.8 \quad \forall \quad G_{0}~>~100~K  
    \end{empheq}
    \label{eq:k_temperature_correlation}
\end{subequations}
\lipsum
\end{document}

MWE 2

\documentclass[a4paper,twoside,12pt]{report}
\usepackage{lipsum}
\usepackage[overload]{empheq}

\begin{document}
\begin{subequations}
\lipsum
    \begin{empheq}[left={H=\empheqlbrace\,}]{align}
        & 2 G_{0} - 2.6 \quad \forall \quad G_{0}~<~100~K \\
        & 2 G_{0} - 9.8 \quad \forall \quad G_{0}~>~100~K  
    \end{empheq}
    \label{eq:k_temperature_correlation}
\end{subequations}
\lipsum
\end{document}

How to remove vertical space between equation and paragraph when using combination of subequations and empheq?

  • 2
    That is probably because lips ends with \par, have you tried \lipsum* or tried a propper hand written test? The par makes the empheq appear as if it had a blank line above it, and that causes a longer than normal spacing (one of the ways you can detect blank lines in the code from the pdf) – daleif Sep 21 '17 at 7:33
  • Yes. I have tried with hand written test. It exists. – nxkryptor Sep 21 '17 at 7:35
  • I've tried to remove both subequations and empheq (replaced it by the align environment). The vertical space remains. It disappears after I drop the empheq package or remove the overload option. Though it disappears for align only. For empheq it strikes again. So I think the issue is in the empheq package and not in subequations. – Sergei Golovan Sep 21 '17 at 8:16
  • I see no particular excess space in MWE2, provided the ending \par of \lipsum is suppressed (\lipsum*). There's no rule about having to do like in MWE1. I'd say that to the contrary it is better to include in subequations also the paragraph parts before and after the equations/displays involved in subequations. – egreg Sep 21 '17 at 8:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.