0

I am using

\documentclass[a4paper,twocolumn]{article}
\usepackage{flushend}

to balance columns on the last page of the document. However, I also want a line between the columns:

\setlength{\columnseprule}{0.4pt}

The problem is that the column separator extends to the bottom of the page, and not the bottom of the text. Like this:

text | text
text | text
     |

Can I set the length of the column separator?

(Note: the balance package can do this, but it has problems with line spacing. So I'd like a solution with flushend, if possible.)

1

The problem seems to be caused by LaTeX itself. Even without the flushend package the rule goes all the way down, if the left column is only partially filled.

I suggest to use the multicol package, which does what you want by default. It is also far more flexible then the twocolumn option.

Here an example:

\documentclass[a4paper]{article}
\usepackage{multicol}
\usepackage{lipsum}

\setlength{\columnseprule}{0.4pt}

\begin{document}
\begin{multicols}{2}
\lipsum[1-4]
\end{multicols}
\end{document}

And next time: please make a minimal working example (starting with \documentclass and ending with \end{document}), which shows the problem. It makes it much easier for the people here to see your problem and answer your question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.