LaTeX command \mathbb gives strange results when using numbers.

For example, \mathbb{1} prints an unintended symbol.

There was a previous question on this topic whose solution involved using the \mathbbol package, but it doesn't seem to be working anymore. The solution posted originates a compilation error.

  • 2
    Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. Please provide a minimal working example (MWE) and the link to the post you mentioned. – CarLaTeX Sep 21 '17 at 14:35
  • 2
    \mathbb{1} has never worked for printing a 1; what “posted solution” are you referring to? – egreg Sep 21 '17 at 14:39
  • @egreg -- there have been some blackboard bold fonts that contained digits as well as letters, and if they were "properly" organized, \mathbb{1} would produce a double-line "1". but the "usual" (original, old) blackboard bold fonts had neither digits nor lowercase. still, we need to know what previous question is being referred to to make sense of this question. – barbara beeton Sep 22 '17 at 0:37
  • @egreg -- The answer I meant was this one. I tried it but my Miktex engine complained about not finding specific fonts. – Antonio Sep 22 '17 at 17:09

Meanwhile I found a solution here. Basically just declare package "bbm" and use command "\mathbbm{1}".

  • mathbbm is not mathbb. – Sigur Sep 22 '17 at 17:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.