MiKTeX problem report dialog box provides following error. However the file is present.

Invalid argument: path="C:\Users\swati\AppData\Local\MiKTeX\2.9\miktex/data/le\df2c24cb21984fa85003c1ecc818ff83.fndb"

Both the file and directory have read and write access. My OS is Windows 10.

  • Welcome to TeX.SX! Please provide us with some context. When does this error message show up (what are you trying to do). Is there some further log? – TeXnician Sep 24 '17 at 10:41
  • I installed basic-miktex-2.9.6361-x64.exe in my windows 10 laptop and then opened MikTex package manager and selected Synchronize. I received the above error in a dialog box. I checked and gave read write permission to all files and folders under MiKTex under Local and tried again with similar results. The file and the path are however very much present. – Swati Banerjee Sep 24 '17 at 10:49
  • Further to my error in MikTex package manager, I ran MikTex Package Manager (Admin). However it ended with another problem report, before even starting Windows API error 87: The parameter is incorrect. Data path="C:\ProgramData\MiKTeX\2.9\miktex/data/le\1756f6ade37d5f870f23c05a7f81e257.fndb" – Swati Banerjee Sep 24 '17 at 11:07
  • 3
    Can you update the fndb (miktex settings (user + admin), button "refresh FNDB")? – Ulrike Fischer Sep 24 '17 at 14:00

This is often caused by another MikTex process running at the same time. Close any other MikTex processes (or just reboot) and try again.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.