3

I've just installed TexMaker with Miktex in a new Windows machine.

As I found some problems with bibtex, I decided uninstall Miktex and Install Tex Live.

And mannually change the paths and executables on configuration page.

But now, I have problems with packages: all the time I got an error about some packages. I didn't get theses errors before decide install Tex Live.

Then I realized my installation became a big mess.

I tried to reset the configuration file with Optoins -> Setting Files -> Reset Settings. The program ends and when I launch it again, the options remains the same.

I uninstalled all programs and installed again, the configuration data is still there.

Is there any way to really reset the configuration file?

5
  • Reset to what? If you have no configuration at all it won't work too. Stop to install and deinstall without any plan and simply go through the configuration and adapt it if something is wrong (normally most of it should work with both texsystems). Sep 25, 2017 at 16:41
  • Sure, the problem is: when I installed at first time with Miktex everything was working ok except bibtex. So I uninstalled Miktex and installed Tex Live. And bibtex worked fine but I have problems with uninstalled packages, that Miktex installs automatically. I return to Miktex but the auto installation doesn't work. So my idea was install everything from scratch Sep 25, 2017 at 20:39
  • @ulrike fischer The problem posed by @Ricardo Brandao addresses a serious problem newcomers would have. Myself, I have been working with TeXMaker/MikTeX for a number of years and have recently installed Texlive as a distribution, just out of interest. I am still wondering how one configures Texmaker to work with a particular distribution. Checking the Options screen on my Texmaker installation shows no mention whatever of MikTeX, and what the user manual has to say on the topic in 1.2 Configuring the latex related commands is unenlightening. If you have the answer, please let us have it! Mar 12, 2019 at 10:44
  • 1
    @ReinhardNeuwirth I don't have texmaker. But if the configuration simply refers to e.g. "pdflatex" it will use whatever texsystem is first in the windows PATH variable. Mar 12, 2019 at 13:20
  • ... it does refer to pdflatex! Mar 12, 2019 at 20:15

1 Answer 1

1

You should search for the ".ini" files of TexMaker in the system and remove them. I had the similar issue before.

In Windows 11, they are under C:\Users\%USERNAME%\AppData\Roaming\xm1\. There are "texmakerapp.ini" and "texmaker.ini"

After removing them, you can have a fresh installation.

(You can manually edit them if you want but that's not a simple job.)

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Feb 2, 2022 at 5:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .