1

Previously, LyX worked perfectly with the images in the final output PDF being in lovely and perfect vector form.

However, I recently formatted my hard disk and reinstalled LyX. I then tried outputting a PDF file, from the exact same LyX and EMF files. However, now the images in the output PDF are rasterized/pixelized/fuzzy.

Not surprisingly, I prefer the first version (vector). Please let me know what I should do to fix this.


I have tried fiddling with the EMF to EPS converter settings but these haven't worked. What I've tried:

Under Tools > Preferences > File Handling > Converters > Enhanced Metafile -> EPS:

  • Changed "convert" to "magick".
  • Remove "-density 300".
  • Unchecking the "Converter File Cache" "Enabled" box.

How these EMF files were produced. I draw my graphs in Microsoft Excel first. I select the graph, copy (Ctrl+C), then paste (Ctrl+V) into LyX. LyX then converted these into EMF files (which were saved in the same folder as the LyX file). So these EMF files were from before I formatted my hard disk (I don't know if that matters). (When formatting my HD I backed up my files on an external HD and now I've copied them back.)

1 Answer 1

2

LyX can detect the following programs that can be used to automatically convert your EMF files to EPS or PDF and preserve them as a vector format: metafile2eps, wmf2eps, and inkscape. If you have one of those installed, go to Tools > Reconfigure and LyX should detect it and use it. If it is still producing a raster image in the final PDF output, I suggest just converting the EMF files manually using one of the programs listed above.

In the future, I would suggest to never using EMF files, and to use formats such as EPS or PDF instead.

You must log in to answer this question.