0

I'm writing a report on Latex and when I build my file, I got 1 error and I have no idea what the problem is. enter image description here

Here the package that I load at the beginning of the document and all my files are save in utf8 format :

enter image description here

  • Welcome to TeX SX! Did you load inputenc with option [utf8], and is your file really encoded in utf8? – Bernard Sep 26 '17 at 12:16
  • Hi Bernard, I just modify my post to include more details. Yes I load inputenc with option [utf8] and I think my files are encoded in utf8. – Noé Brice Sep 26 '17 at 12:42
  • I asked the second question because it already happened me to have downloaded files I thought utf8-encoded, but which were not, and converting them later, with a mix of utf8 and non-utf8 characters resulted in a mess. You should check if your file is really utf8-encoded. TeXmaker, for instance, will warn you if it's not. – Bernard Sep 26 '17 at 12:49
  • Strange. E0 doesn't map to è but à. – n.r. Sep 26 '17 at 13:11
  • 1
    @n.r. the number shown is pretty meaningless, latex isn't doing a lot of error checking here and is trying to decode the three (single byte) characters èse as three bytes of a UTF-8 encoding but that isn't a legal UTF-8 string so it just falls out as some random codepoint. – David Carlisle Sep 26 '17 at 14:23
2
\documentclass{article}

\usepackage[utf8]{inputenc}

\begin{document}

zzz èse zzz

\end{document}

If you take the above file and save it in latin-1 (iso-8859-1) encoding then it produces the error below matching your screenshot. If you save it in UTF-8 which is the encoding that has been declared to LaTeX then it runs without error.

! Package inputenc Error: Unicode char �se (U+E0)
(inputenc)                not set up for use with LaTeX.

See the inputenc package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.7 zzz �se
            zzz
? 
0

Thank you all for your answers; I have solved my problem. It was some foreign characters in my bilbiography file. I use Zotoro to manage my bibliography and I used to automatically import reference from website to zotero.I include my bibliography in my report by exporting it directly from zotero in bibtex format. Considering the references come from different website, it seems like some reference have characters that weren't supported;

To find them, I use notepad++ to search non-ASCII character in my bibliography file, and I find some characters, mainly on foreign authors names; I also changed the encoding of all my files from utf8 to latin1 and load [latin1]{inputenc}. Things work fine now.

I just don't get why latin1 in working better than utf8. I'm on windows.

  • utf8 will work as well as latin1 (and is better option going forward) but you have to ensure all files are in that format (bibtex though by default can't really handle either and wants \'e) but the error showed that you had files in latin1 declared as utf-8 – David Carlisle Sep 26 '17 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.