0

The following code generates the error message

"LaTeX Error: \begin{table*} on input line 69 by \end{table}

\begin{table}[!ht]
    \caption{Variable assignment to blocks in the three-form design.}
    \begin{tabular}{lll}
        \toprule
        Rotation Block A & Rotation Block B & Rotation Block C \\
        \midrule
        CARINFO & SCINTACT & PERSCIE\\
        CARPREP & SCINVEST &  RESPDEV \\
        ENVAWARE & SCSCIE & SCAPPLY \\
        INSTSCIE  & ENVOPT &  SCHANDS \\
        JOYSCIE & ENVPERC & SCIEACT \\
        SCIEFUT & GENSCIE &  SCIEEFF \\
                & INTSCIE & \\        
        \bottomrule
    \end{tabular}
 \end{table}

When I type set the whole document with this part commented out, it runs just fine. Any thoughts?

9
  • 2
    Welcome to TeX.SE. Apart from design issues: Your table works for me, if copied into a small sample document that is compilable (which is actually your job to provide, not our job). Especially, I don't get a table* error message
    – user31729
    Sep 28 '17 at 21:17
  • You are right. It works in a sample document. But, not in my full document as I mentioned. Not sure what the table* message is getting at, but that is the problem.
    – David
    Sep 28 '17 at 21:36
  • And sorry to have not supplied a compliable document. I'm new to TeX.SE.
    – David
    Sep 28 '17 at 21:41
  • Are you including the booktabs psckage? Sep 28 '17 at 21:52
  • The example show \begin{table} .... \end{table} that have nothing to do with the question title, and of course should work, as well as \begin{table*} .... \end{table*}, but the error message say that you are using really \begin{table*} .... \end{table} that of course is wrong. Otherwise you should clarify what are you doing really.
    – Fran
    Sep 28 '17 at 22:04
1

Short answer: add an asterisk to \end{table} → → → \end{table*}

Any open environment should be closed by the same environment. Consider this nonsense non-working minimal example:

\documentclass{article}
\begin{document}
\begin{figure}
asdasd  
\end{table}
\end{document}

This will produce the same type of error:

LaTeX Error: \begin{figure} on input line 3 ended by \end{table}.

The same apply to starred versions. Both \begin{table*} and \begin{figure*} are differents environments that table and figure and therefore should end with the correspondent \end{table*} and \end{figure*}, respectively.

3
  • If I compile the document with \begin{table*} and \end{table*}, I get the following error message: "Runaway argument? ! File ended while scanning use of \efloat@xflot.
    – David
    Sep 28 '17 at 23:33
  • @David This is the x-1 next error. Maybe because you are using endfloat? See tex.stackexchange.com/questions/62278/…. Without construct a minimal working example (MWE) starting with \documentclass{...} and ending with \end{document} that reproduce exactly that error, find the x-1, x-2,... errors of your document could be a endless headache for you and an impossible mission for us.
    – Fran
    Sep 29 '17 at 6:15
  • @David: Please do as Fran asked you: Provide a compilable document
    – user31729
    Oct 3 '17 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.