1

I installed texlive by script so I can have the latest version.

When using xetex it gives the following error message:

I can't find the format file `xetex.fmt'!

sudo fmtutil-sys --all

did not helped.

another solution is:

sudo tlmgr install latex latex-bin

I gives the error message:

/usr/bin/tlmgr: could not find a usable xzdec.

using tlmgr to install xzdec gives the same error message.

Installing xzdec from ubuntu repository gives the following error message:

Unknown directive ...containerchecksum 06c8c1fff8b025f6f55f8629af6e41a6dd695e13bbdfe8b78b678e9cb0cfa509826355f4ece20d8a99b49bcee3c5931b8d766f0fc3dae0d6a645303d487600b0... , please fix it! at /usr/share/texlive/tlpkg/TeXLive/TLPOBJ.pm line 210, line 5761.

Which is logical because there not the same version.

How can I install xzdec?

Thanks

  • the unknown directive I think means that you are running an old pre-2017 tlmgr but trying to update from the current 2017 repository which includes a checksum check on file transfers,. – David Carlisle Oct 3 '17 at 19:22
  • is the texlive you installed in /usr/bin or is that a pre-existing system installation? If you have installed a texlive from tug it's usually in /usr/local/texlive/2017 – David Carlisle Oct 3 '17 at 19:24
  • texlive is installed in /usr/local/texlive/2017. – Redman Oct 3 '17 at 20:15
  • in that case you need to fix your path or explicitly use the tlmgr from there and not the one you are using from /usr/bin/tlmgr – David Carlisle Oct 3 '17 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.