0

When I run the following code, if I type C-c C-backtick after being notified of the presence of errors, AUCTeX says no more errors and it doesn't point me to the & in excess. The log file shows the error but AUCTeX doesn't point me to it. If I comment-out \usepackage{chemmacros} it works flawlessly.

\documentclass{article}

\usepackage{chemmacros}

\begin{document}

\begin{tabular}{ll}
  &&& \\ % One too much
  &&
\end{tabular}

\end{document}

Update:

I have Emacs 24.5.1, AUCTeX 11.91.0, Chemmacros v5.8b. I've tried with an init file consisting only of

(require 'reftex)

and the behaviour is the same.

  • 1
    it worked for me as far as I can tell. You probably need exact emacs and auctex version numbers and probably more of a question for the emacs stackexchange than here, – David Carlisle Oct 3 '17 at 21:22
  • Works for me as well (Emacs 24.3.1 with AUCTeX 11.87) – clemens Oct 3 '17 at 22:55
  • @DavidCarlisle It's also suited for this site, since giordano monitors the auctex tag. – Henri Menke Oct 4 '17 at 1:12
  • @clemens See my updated question – Arch Stanton Oct 4 '17 at 12:34
  • @DavidCarlisle see update. Thanks for the help. – Arch Stanton Oct 4 '17 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.