2

Today I updated my operating system to Ubuntu 14.04 and now I run into the following problem:

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\begin{document}
 This is a MINIMUM WORKING EXAMPLE.
\end{document}

gives the error message:

! LaTeX Error: Unknown option 'english' for package 'babel'. See the LaTeX
manual or LaTeX Companion for explanation.

I am using Texmaker and this seems to happen for all the different language options, even though Texlive is fully installed. Thank you for your help.

Regards Michael

closed as off-topic by Andrew Swann, Stefan Pinnow, siracusa, TeXnician, dexteritas Sep 7 '18 at 10:09

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Welcome to TeX.SX! Can you show what's the output of kpsewhich english.ldf from the terminal? – egreg Oct 3 '17 at 21:08
  • /usr/share/texlive/texmf-dist/tex/generic/babel-english/english.ldf – Michael Scheitz Oct 3 '17 at 21:12
  • 1
    OK. Can you find the version number of babel.sty in the log file? It's right at the top. – egreg Oct 3 '17 at 21:13
  • Babel <3.9h> and hyphenation patterns for 78 languages loaded. – Michael Scheitz Oct 3 '17 at 21:25
  • 4
    I'm voting to close this question as off-topic because it was solved by updating the distribution and cleaning out the auxiliary files – Andrew Swann Sep 7 '18 at 7:25
1

I have found a solution that "works for me" and is not mentioned in any related discussions. I am using LuaLaTeX with TeXlive 2017, but I don't think that is essential.

My solution: Create a file named babel-english.sty. You may leave its contents empty. Put the file in the same folder as your main *.tex document. Discard its existing *.aux and *.synctex.gz files. Then re-compile your *.tex document.

As best as I can determine, when babel loads with default language english it looks for package babel-english. Even though babel-english is installed, it has only data files, not a *.sty file. So, babel cannot find it. When you make a fake babel-english.sty file available, then babel proceeds normally.

You may also create folder (texmf-local)/text/generic/babel-english and place the fake file there, then update your file name database (on Ubuntu, command line mktexlsr).

As I said, that worked for me. Seems like it is a transient, possibly installation-dependent, problem. EDIT: Interesting! Once I got this working the first time, I was able to remove the fake sty file, delete the aux and related files, and it kept working. Very mysterious. That might explain why the problem is not seen more often.

Not the answer you're looking for? Browse other questions tagged or ask your own question.