2

When I use table* while having XePersian package, I get this error:

Incomplete \iffalse; all text was ignored after line 10.

A sample that returns this error is this one:

\documentclass[12pt,a4paper]{report}
\usepackage[utf8]{inputenc}
\usepackage{xepersian}
\settextfont{Arial}
\begin{document}    
    \begin{table*}
        \caption{نمونه}
    \end{table*}
\end{document}

Could someone guide me on solving this problem?

Edit Here is my log file

3
  • xepersion (I think) requires xetex in which case you should not use inputenc Oct 4, 2017 at 19:01
  • @DavidCarlisle Removing that line changed nothing and I still get the same error!
    – 01000110
    Oct 4, 2017 at 19:03
  • I get no error in texlive 2017 add \listfiles to your preamble and compare with a version I'll post in an answer box shortly (not a real answer) Oct 4, 2017 at 19:05

1 Answer 1

0

It works in texlive 2017 and adding \listfiles shows the following list, compare your package versions.

 *File List*
  report.cls    2014/09/29 v1.4h Standard LaTeX document class
  size12.clo    2014/09/29 v1.4h Standard LaTeX file (size option)
inputenc.sty    2015/03/17 v1.2c Input encoding file
xepersian.sty    2017/09/06 v19.3 Persian typesetting in XeLaTeX
fontspec.sty    2017/09/22 v2.6e Font selection for XeLaTeX and LuaLaTeX
   expl3.sty    2017/09/18 L3 programming layer (loader) 
expl3-code.tex    2017/09/18 L3 programming layer 
l3xdvipdfmx.def    
  xparse.sty    2017/09/18 L3 Experimental document command parser
fontspec-xetex.sty    2017/09/22 v2.6e Font selection for XeLaTeX and LuaLaTeX
 fontenc.sty
   tuenc.def    2017/04/05 v2.0i Standard LaTeX file
fontspec.cfg
xepersian-persiancal.sty    2012/07/25 v0.2 provides Persian calendar
xepersian-mathsdigitspec.sty    2017/09/02 v1.1.4 Unicode Persian maths digits 
in XeLaTeX
    bidi.sty    2017/09/19 v31.3 Bidirectional typesetting in plain TeX and LaT
eX
   iftex.sty    2013/04/04 v0.2 Provides if(tex) conditional for PDFTeX, XeTeX,
 and LuaTeX
biditools.sty    2017/09/19 v1.0 Programming tools for bidi package
zref-abspage.sty    2016/05/21 v2.26 Module abspage for zref (HO)
zref-base.sty    2016/05/21 v2.26 Module base for zref (HO)
 ltxcmds.sty    2016/05/16 v1.23 LaTeX kernel commands for general use (HO)
infwarerr.sty    2016/05/16 v1.4 Providing info/warning/error messages (HO)
kvsetkeys.sty    2016/05/16 v1.17 Key value parser (HO)
etexcmds.sty    2016/05/16 v1.6 Avoid name clashes with e-TeX commands (HO)
ifluatex.sty    2016/05/16 v1.4 Provides the ifluatex switch (HO)
kvdefinekeys.sty    2016/05/16 v1.4 Define keys (HO)
pdftexcmds.sty    2017/03/19 v0.25 Utility functions of pdfTeX for LuaTeX (HO)
   ifpdf.sty    2017/03/15 v3.2 Provides the ifpdf switch
 auxhook.sty    2016/05/16 v1.4 Hooks for auxiliary files (HO)
atbegshi.sty    2016/06/09 v1.18 At begin shipout hook (HO)
 xkeyval.sty    2014/12/03 v2.7a package option processing (HA)
 xkeyval.tex    2014/12/03 v2.7a key=value parser (HA)
latex-xetex-bidi.def    2017/05/06 v1.2.9 bidi adaptations for `latex.ltx' for 
XeTeX engine
footnote-xetex-bidi.def    2017/08/09 v1.1 bidi footnote macros for XeTeX engin
e
report-xetex-bidi.def    2017/06/09 v0.8 bidi adaptations for standard report c
lass for XeTeX engine
loadingorder-xetex-bidi.def    2015/10/16 v0.96 making sure that bidi is the la
st package loaded
loadingorder-xepersian.def    2017/09/06 v0.4 making sure that xepersian is the
 last package loaded
footnote-xepersian.def    2017/08/09 v0.6 footnote macros for xepersian package

report-xepersian.def    2010/07/25 v0.2 adaptations for standard report class
 ***********
4
  • I added \listfiles to preamble part, but I don't know where this list appears.
    – 01000110
    Oct 4, 2017 at 19:18
  • @01000110 it appears on the terminal and also in the log file, where any other warnings or messages from tex appear. Oct 4, 2017 at 19:33
  • I included link to my log file. I couldn't find anything similar to your output in that! I guess my old 2014 TeXlive causes these issues.
    – 01000110
    Oct 4, 2017 at 19:43
  • @01000110 if you add \listfiles then the list appears at the end of the log as latex processes \end{documen} ah so that means you need an error free document so it gets to the end. i did not follow the link as the link you give is to a page full of adverts and I can not read any of the text so it was not safe to guess. You can add the log to the question. but 2014 is pretty old, note the bidi and xepersion packages I used are from 2017 so you will certainly have older packages, so I would update. Oct 4, 2017 at 20:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .