0

Following the jump to pdf option in TeXworks causes TeXworks to shutdown. Same for jump to source.

This is on a new Ubuntu Xenial install. Have been using TeXworks for years and never got this behavior.

Any thoughts?


Following up on @diabonas:

dpkg -s texworks yields

Package: texworks
Status: install ok installed
Priority: extra
Section: editors
Installed-Size: 5682
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Version: 0.5~svn1363-6build2
Depends: libc6 (>= 2.14), libgcc1 (>= 1:3.0), libhunspell-1.3-0 (>= 1.3.3), libpoppler-qt4-4 (>= 0.20.1), libqt4-dbus (>= 4:4.5.3), libqt4-script (>= 4:4.5.3), libqt4-scripttools (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.8.0), libqtgui4 (>= 4:4.8.0), libstdc++6 (>= 4.1.1), libsynctex1
Recommends: gsfonts, poppler-data, texlive-latex-base, texworks-help-en
Suggests: texlive-xetex, texworks-scripting-lua, texworks-scripting-python

and dpkg -s libsynctex1 gives

Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 138
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Multi-Arch: same
Source: texlive-bin
Version: 2015.20160222.37495-1
Depends: libc6 (>= 2.14), zlib1g (>= 1:1.1.4)
Description: TeX Live: SyncTeX parser library
 Library for SyncTeX parsing support.

Output of synctex help

This is SyncTeX command line utility, version 1.2
usage: synctex <subcommand> [options] [args]
Synchronize TeXnology command-line client, version 1.17

The Synchronization TeXnology by Jérôme Laurens is a new feature of recent  TeX engines.
It allows to synchronize between input and output, which means to
navigate from the source document to the typeset material and vice versa.

Available subcommands:
   view     to perform forwards synchronization
   edit     to perform backwards synchronization
   update   to update a synctex file after a dvi/xdv to pdf filter
   help     this help

Type 'synctex help <subcommand>' for help on a specific subcommand. 
There is also an undocumented test subcommand.
  • Welcome to TeX.SX! This sound like a problem with SyncTeX. What version of TeXworks and SyncTeX are you using (this can be found in the output of dpkg -s texworks and dpkg -s libsynctex1)? – diabonas Oct 8 '17 at 18:18
  • Possibly related questions concerning the Texmaker editor: Undefined symbol: synctex_next_result when starting Texmaker (closed due to lack of debugging information), “undefined symbol: synctex_next_result” when editors try to use SyncTex (OP installed a custom PPA, which lead to package version conflicts). – diabonas Oct 13 '17 at 12:51
  • Thank you for the added information - the seems to be in order, so no clues as to what goes wrong on your system, unfortunately. It could be related to the bug TeXworks 0.6.2 and 0.7 are not compatible with TeXLive 2017 - are you using TeX Live 2017, by any chance, or have you installed it from the official Ubuntu repository, using apt install texlive or similar? If the former is the case, the output of synctex help would be of interest. – diabonas Oct 14 '17 at 14:49
  • Another way to get some more information about the crash is to execute texworks in a terminal to start the editor, which gives some additional debug output on the terminal. Reproduce the crash an see whether there is some kind of error message. – diabonas Oct 14 '17 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.