1

In my bibliography (I use natbib) I wanted to use @inbook so that I could cite the author name, the edition, the publishing house, the year of publication and the page numbers in my thesis. I thought that inbook was the most apt bibliographic index for my job. The entries look something like this

@inbook{a,
    author = {Anton, H.},
    title = {title},
    booktitle = {Calculus: A New Horizon, 6th ed.},
    date = {1999},
    OPTbookauthor = {bookauthor},
    OPTeditor = {editor},
    OPTeditora = {editora},
    OPTeditorb = {editorb},
    OPTeditorc = {editorc},
    OPTtranslator = {translator},
    OPTannotator = {annotator},
    OPTcommentator = {commentator},
    OPTintroduction = {introduction},
    OPTforeword = {foreword},
    OPTafterword = {afterword},
    OPTsubtitle = {subtitle},
    OPTtitleaddon = {titleaddon},
    OPTmaintitle = {maintitle},
    OPTmainsubtitle = {mainsubtitle},
    OPTmaintitleaddon = {maintitleaddon},
    OPTbooksubtitle = {booksubtitle},
    OPTbooktitleaddon = {booktitleaddon},
    OPTlanguage = {language},
    OPToriglanguage = {origlanguage},
    OPTvolume = {volume},
    OPTpart = {part},
    OPTedition = {6th ed.},
    OPTvolumes = {volumes},
    OPTseries = {series},
    OPTnumber = {number},
    OPTnote = {note},
    OPTpublisher = {Wiley},
    OPTlocation = {Newyork},
    OPTisbn = {isbn},
    OPTchapter = {chapter},
    OPTpages = {p324-327},
    OPTaddendum = {addendum},
    OPTpubstate = {pubstate},
    OPTdoi = {doi},
    OPTeprint = {eprint},
    OPTeprintclass = {eprintclass},
    OPTeprinttype = {eprinttype},
    OPTurl = {url},
    OPTurldate = {urldate},
}

But, the output comes out to be very limited as this:

bib

I don't exactly understand what is the issue or don't exactly know whether there's a better way to do it. Any help is appreciated.

  • 1
    What is your bibliography style? – Troy Oct 7 '17 at 3:52
  • 1
    Looks like your template generator is set up for use with biblatex. Normal bibliographystyles do not know date but year and month. booktitle should be known by most BibTeX styles. – Johannes_B Oct 7 '17 at 5:49
  • @Johannes_B So what should be the way to address the problem? – ubuntu_noob Oct 7 '17 at 10:08
  • Which program gave you all the OPTbookauthor etc. stuff? Jabref? Endnote? Citavi? Mendelew? Probably there are settings to tweak to use the basic bibtex fields, instead of the modern biblatex fields. Or use biblatex instead -> en.wikibooks.org/wiki/LaTeX/… – Johannes_B Oct 7 '17 at 11:52
  • @Johannes_B No, I just clicked the bibliography option and selected inbook from my texstudio so as to fill in the details myself – ubuntu_noob Oct 10 '17 at 7:20
1

Something like this?

MWE (package filecontents is only used to have bib file and TeX file together in one compilable MWE):

\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@Book{Goossens,
  author    = {Goossens, Michel and Mittelbach, Frank and 
               Samarin, Alexander},
  title     = {The LaTeX Companion},
  edition   = {1},
  publisher = {Addison-Wesley},
  location  = {Reading, Mass.},
  year      = {1994},
}
@Book{adams,
  title     = {The Restaurant at the End of the Universe},
  author    = {Douglas Adams},
  series    = {The Hitchhiker's Guide to the Galaxy},
  publisher = {Pan Macmillan},
  year      = {1980},
}
@inbook{a,
  author    = {Anton, H.},
  title     = {Calculus: A New Horizon},
  year      = {1999},
  edition   = {6},
  series    = {series},
  publisher = {Wiley},
  chapter   = {chapter},
  pages     = {324--327},
}
\end{filecontents*}


\documentclass[10pt,a4paper]{article}

\usepackage{natbib}
\usepackage{hyperref}

\begin{document}

This is text with \cite{Goossens} and \cite{adams}.

\nocite{*} % to test all bib entrys
\bibliographystyle{plain} %
\bibliography{\jobname}

\end{document}

with the result:

resulting page

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.