2

I am using Fibeamer beamer theme(can be accessed here The \footnote and \footfullcite commands don't produce any output. However the references are properly rendered with a frame showing \printbibliography. I suspect this has to do with the footer definition in the theme's style file. However I m unable to get this to work.

Here's a MWE

    \documentclass{beamer}
\usetheme[microtype,faculty=fsps]{fibeamer}
\usepackage[style=numeric,doi=false,url=false,backend=biber]{biblatex}
\addbibresource{mybib.bib}

\author{Karthik}
\title{Presentation title}

\begin{document}
    \maketitle
\begin{frame}{ First slide }
    Testing citations \footfullcite{Smith2012}
\end{frame} 
\end{document}
0

1 Answer 1

4

On page 9 of the fibeamer documentation we find

setspace - This package is used to adjust the leading to 115 %. Loading this package breaks any top-level footnotes without the [frame] optional parameter specified. This is a known bug.

So while \footnote{foo} does not work, \footnote[frame]{bar} does. We now need to tell biblatex to insert [frame] whenever it calls footnotes. This can be done with

\makeatletter
\renewrobustcmd{\blx@mkbibfootnote}[2]{%
  \iftoggle{blx@footnote}
    {\blx@warning{Nested notes}%
     \addspace\mkbibparens{#2}}
    {\unspace
     \csuse{footnote#1}[frame]{\protecting{\blxmkbibnote{foot}{#2}}}}}
\makeatother
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.