2

I'm trying to use Pandoc to generate an MLA-styled paper from a Markdown document, with LaTeX as an intermediary.

Everything is working perfectly so far (well, for PDF output, anyway)—except the Works Cited page, which is completely empty.

I'm using pandoc --verbose paper.md.txt --template mla.tex -s -S -o "James Edington EH105 Paper 1.pdf"

My template mla.tex is so (templated off the instructions from Ryan Aycock's mla-paper as well as Jackson 13's mla13.sty):

\documentclass[12pt,letterpaper]{article}
\usepackage{ifpdf}
\usepackage{mla}
\usepackage[backend=bibtex8]{biblatex}
\addbibresource{$bibliography$}
\begin{document}
\begin{mla}{$author_firstname$}{$author_lastname$}{$instructor$}{$class$}{\today\\Word Count: $word_count$}{$title$}
$body$

\nocite{s11}
\pagebreak
\begin{center}
Works Cited
\end{center}
\printbibliography
\end{mla}
\end{document}

and paper.md.txt is structured so:

---
title: 'Maslow and Mandel: Needs hierarchy and human priorities in _Station Eleven_'
author_firstname: 'James'
author_lastname: 'Edington'
instructor: 'William Wilkerson'
class: 'EH 105'
word_count: '311'
bibliography: 's11.bib'
---

_"Survival is insufficient"_, the motto emblazoned…

and s11.bib consists of just this:

@book{s11,
  author    = {Emily St. John Mandel},
  title     = {Station Eleven},
  publisher = {Vintage},
  year      = 2015,
  month     = 6,
  isbn      = {0804172448}
}

@article{maslow,
  author = {Abraham Harold Maslow},
  title = {A Theory of Human Motivation},
  journal = {Psychological Review},
  year = {1943},
  volume = {50},
  number = {4},
  pages = {430-437},
}

I'm using MiKTeX 2.9 (64-bit) on Windows 10.

The full output log of the command is at http://pastebin.com/rR5pxGag, but the relevant section seems to be:

No file input.bbl.

(Which, I imagine, is what's leading to the subsequent errors LaTeX Warning: Empty bibliography, LaTeX Warning: There were undefined references, and Package biblatex Warning: Please (re)run BibTeX on the file(s):)

I have tried backend= bibtex, bibtex8, and biber; the error message does not change substantially.

So, what do I need to do to get Pandoc to feed a .bib* file into \printbibliography?
(* I am 100% OK with converting this file into other formats)

  • Welcome to TeX.SX! I don't use pandoc, so perhaps disregard my comment, but the problem appears to be that there is no bbl file. Have you tried manually running bibtex by hand? Failing this latex the document first, then run bibtex and then pandoc? (Quite likely, yourbackend=... commands should do this but they don't seem to be working...) – Andrew Oct 9 '17 at 16:45
  • @Andrew If I run bibtex s11.bib I get an error I couldn't open file name `s11.bib.aux' – JamesTheAwesomeDude Oct 9 '17 at 16:55
  • 3
    Well, you do not run bibtex on the bib file, but on the tex file (without extension). – TeXnician Oct 9 '17 at 17:03
  • I thought you needed to call pandoc with some bibliography-related commands to get a bibliography. Something like --biblatex --bibliography=s11.bib. (I always forget because I don't use pandoc except for rather simple tasks....) – jon Oct 10 '17 at 3:35
  • @TeXnician My tex file is just a template. I feed the markdown into it; I'm writing in markdown. The tex file as-is doesn't have citations in it. And @jon that command didn't work; I got the same No file input.bbl error again. – JamesTheAwesomeDude Oct 10 '17 at 5:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.