6

Apologies if this has been asked and answered before, but while I've been able to resolve some of my queries from this resource, I can't seem to find an answer to this one.

I have my own preferred bibliography style for my PhD dissertation, and I've managed to produce almost exactly what I want using makebst.tex. My style (mythesis.bst) removes all full stops (aka periods) from acronyms and abbreviations, including author name initials and journal abbreviations. However, "et al." irritatingly appears with the full stop in both the citation and bibliography. Is there a tweak I can make to the mythesis.bst file and/or \cite series of commands to remove the full stop? I also have a horrible feeling that "ed." (for editor) is going to appear with a full stop too, so a similar question applies.

I'm using the TexLive 2011 distribution on Windows 7 and JabRef as my bibliography manager. Please be gentle, as (a) I'm a LaTeX beginner and (b) I'm a biologist!

4
  • 6
    You do know that 'et al.' is an abbreviation for 'et alii', and therefore with most styles requires a full stop at the end?
    – Joseph Wright
    Dec 29, 2011 at 17:10
  • 1
    Have you tried search-and-replacing et al. with et al in the bst file?
    – You
    Dec 29, 2011 at 17:55
  • Thanks @Joseph, but sadly I'm old enough to have O Level Latin, so was aware that 'et al.' is an abbreviation for 'et alii' (or 'et alteri'). I just feel that it's inconsistent to remove full stops for other abbreviations (eg journal names) and not this one. Incidentally, some reputable sources (eg Mary-Claire van Leunen in her 'Handbook for Scholars') hold that 'et al.' should never be in italics – but I ignore that too! Dec 30, 2011 at 9:24
  • @MarkBirtwistle I'm only aware of two general styles for abbreviations in English. The US tradition uses . for everything, and the UK one omits the . where the abbreviation retains the last letter of the full text. It's true that some styles omit the . for journal abbreviations, but I think stick to a standard method in the text. On the italic business, US publishers seem to have dropped italic for a lot of 'common' foreign terms.
    – Joseph Wright
    Dec 30, 2011 at 9:32

1 Answer 1

7

Since you've already created a custom bibliography style (.bst) file, you could open it in an editor, search for all "et~al." and "et al." strings, and replace them with "et~al".

Customizing the precise contents of the "et~al." string is one of the few options that the makebst program doesn't offer automatically. However, editing the .bst file in the way described in the preceding paragraph isn't too onerous a task, I dare say. :-)

2
  • Many thanks @Mico! I had searched for 'et al' in the .bst file, but it hadn't occurred to my feeble brain to search for the hard space version! Problem solved. Dec 30, 2011 at 9:28
  • @MarkBirtwistle: you're welcome! It usually takes some time to get the hang of things related to BibTeX. :-)
    – Mico
    Dec 30, 2011 at 12:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .