1

I use \doendnotesbysection{X} and encountered a problem using an \Xendnote in an \edtabular-environment and a \ledsidenote in the same section: There appear empty entries in the endnote-apparatus.

Here the MWE:

\documentclass[12pt,a4paper]{scrbook}
\usepackage[utf8]{inputenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}

\usepackage{reledmac}
\usepackage{reledpar}
\linenummargin{inner} 
\sidenotemargin{outer} 

\let\Bfootnoterule=\relax
\Xnotenumfont[B]{\bfseries}
\Xendnotenumfont[B]{\bfseries}
\Xendparagraph[B]
\Xendbeforepagenumber[B]{}
\Xendafterpagenumber[B]{}
\Xendlemmaseparator[B]{\rbracket}
\renewcommand*{\printnpnum}[1]{} % Keine Seitenzahlen in Endnotes
\Xtwolines[B]{f.}
\Xtwolinesbutnotmore[B]
\Xendtwolines[B]{f.}
\Xendtwolinesbutnotmore[B]


\begin{document}

\subsubsection{Example} % it's a subsubsection to simulate my original document.
\beginnumbering
\pstart\noindent
\ledsidenote{[52r]}%
    Figura testimoniorum planetarum in 12 domibus eorum, quantas habeant uirtutes, quilibet in qualibet.
\pend
\bigskip
\pstart
    \begin{center}
        \begin{edtabularl}
            Pro domo & & 52 & \\
            Pro exaltatione & & 43 & \\
            Pro triplicitate & & 34 & 
            \edtext{Ptolemaei}{
                \Bfootnote{Ptolomei}} \\
            Pro termino & & 21 & \\
            Pro facie & \edatright[\text{Habent testimonia}]{\}}{2.5\baselineskip} \edatleft[]{\{}{2.5\baselineskip} & 1 &
        \end{edtabularl}
    \end{center}
\pend
\endnumbering

\doendnotesbysection{B}
\end{document}

It may not be super minimal, but I tried to reconstruct the appearance that I actually use in my original document.

If you delete the \ledsidenote, the endnote shows up totally fine. Also, if you use \Xfootnote, it works, too, but I need endnotes and \ledsidenote.

Is there a way to get around this problem using endnotes and \ledsidenote anyway?

  • Are there no comments/answers because it's too complex or because it's too trivial? I'd appreciate any help and suggestions. – Latin-TeX Oct 17 '17 at 7:13
  • Because not a lot of people use reledmac/reledpar, and because my computer is broken, so I don't look everyday on new reledmac topic on SE. I am looking on your problem. – Maïeul Oct 17 '17 at 15:47
  • I have tried your example., and I can have both ledsidenote and endnote. Cf overleaf.com/read/gdjzhbmjhzgz – Maïeul Oct 17 '17 at 15:51
  • Yes, there is no error. But there are two "empty" endnotes ("1 ] Ptolomei") and one correct ("5 Ptolemaei] Ptolomei"), although there should only be only the one correct. When deleting the \ledsidenote or changing the endnote to a footnote, only the correct one appears. But I need both: the endnote and the ledsidenote. So, my question is: Is there a way to have these both, without the "empty" endnotes? – Latin-TeX Oct 18 '17 at 7:21
  • 1
    That is a bug. Please open an issue on github. I will look on it as soon as will get a working computer. – Maïeul Oct 18 '17 at 7:54
1

The bug (which was not directly related to sidenotes) has been fixed on reledmac 2.24.2, just send on CTAN.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.