1

I have all my references separated into multiple .bib files. When I try to compile my document - only the first bib file is used and the others are ignored. Here is a basic example with just two bib files:

\documentclass[]{article}

\title{Agricultural Crop Characterization using Spatio-temporal Scattering Properties of Polarimetric SAR data and a Deep Learning Framework.}
\author{Shauank De}
\date{}

\begin{document}

\maketitle

\input{0_Problem_Statement}
\input{1_introduction}
\input{2_Science}
\input{3_Methodology}

\section{Science Background}

\bibliographystyle{IEEEtran}
\bibliography{References/Proposal_Agri , References/polsar}
\end{document}

It only pulls information from whichever bib file is listed first. I even tried using sharelatex - and I have the same result.

Sharelatex link: https://www.sharelatex.com/project/59e1b9dad294f4676c032167

Here is my log file:

Process started: bibtex.exe "SD_Agri_2017"

This is BibTeX, Version 0.99d (MiKTeX 2.9)
The top-level auxiliary file: SD_Agri_2017.aux
The style file: IEEEtran.bst
White space in argument---line 11 of file SD_Agri_2017.aux
 : \bibdata{References/Proposal_Agri,
 :                                    References/polsar}
I'm skipping whatever remains of this command
Database file #1: References/Proposal_Agri.bib
Repeated entry---line 38 of file References/Proposal_Agri.bib
 : @article{zhang2009mapping
 :                          ,
I'm skipping whatever remains of this entry
Warning--I didn't find a database entry for "da2008land"
Warning--I didn't find a database entry for "lee2004unsupervised"
-- IEEEtran.bst version 1.14 (2015/08/26) by Michael Shell.
-- http://www.michaelshell.org/tex/ieeetran/bibtex/
-- See the "IEEEtran_bst_HOWTO.pdf" manual for usage information.
Warning--empty journal in wilkinson2006crop

Done.
(There were 2 error messages)

Process exited normally

Can someone point me to what I am doing wrong?

2

I discovered the source of the error. You can't have spaces in the \bibliography{References/Proposal_Agri , References/polsar} command.

The correct command is: \bibliography{References/Proposal_Agri,References/polsar}

  • 1
    Side-note: Thanks, weird \latex bug for wasting my morning. – shaunakde Oct 14 '17 at 7:28
  • Morning wasted? The log file tells you that the white space is the reason. – Johannes_B Oct 14 '17 at 9:21
  • One of the many times in life I've wished I was smarter :( Now that you point it out, ts clear as day. But I was in a frantic panic rush this morning. – shaunakde Oct 14 '17 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.