0

I have a question using the LyX.

I first do: Insert -> math -> numbered formula, then Insert -> math -> aligned environment

but \allowdisplaybreaks does not work.

How can I break numbered equation into different pages?

2

With what you're doing, you end up with LaTeX code for your equation similar to

\begin{equation}
\begin{aligned}
  aligned &= math
\end{aligned}
\end{equation}

And that is the problem, you can't have page breaks inside an equation environment, even if it contains an aligned.

Instead what you must use is an align environment. Instead of the "Numbered formula", choose Insert --> Math --> AMS align. Then right click in the formula, and choose "Number whole formula" (shortcut Alt + MN. With that you end up with code like

\begin{align}
  aligned &= math
\end{align}

and page breaking between the lines of this one will work, when \allowdisplaybreaks is in effect.

Of course, this will make each line numbered, instead of having a single number for the entire block.

| improve this answer | |
  • Thank you very much for your reply Torbjørn T. There is not any way to give only one number to the entire block? – Lithium Oct 17 '17 at 19:33
  • @user145703 Forgot to mention something about that. You can disable numbering for individual lines by right clicking in the equation. I don't have any better ideas. – Torbjørn T. Oct 17 '17 at 20:03
  • I did this. Insert --> Math --> AMS align. Then type equations. Since I add \allowdisplaybreaks in the Setting --> LaTex preamble, now I can see that the equation is shown in different pages. But there is not any equation number at the end of every line, which is different from what you said. And now in the AMS align, Insert -> math -> numbered formula cannot be selected any more. – Lithium Oct 18 '17 at 0:20
  • @user145703 Oops, sorry, it's unnumbered by default. Right click in the align and choose "Number whole formula". – Torbjørn T. Oct 18 '17 at 9:34
  • Thank you very much. Yes. I tried this. Insert --> Math -->numbered formula. The right click, and select AMS environment -->AMS align environment. In this case, \allowdisplaybreaks works. – Lithium Oct 18 '17 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.