2

The MWE below produces a shorthand list as expected.

% !TEX TS-program = xelatexmk
 \documentclass{memoir}

\usepackage[%
    notes,annotation,backref=true,
    block=space,refsection=chapter,
    autopunct=true,firstinits,
    backend=biber
    ]{biblatex-chicago}

\begin{filecontents}{Aw.bib}
@book{VS:18,
    Author = {Horst Klengel},
    Language = {german},
    Location = {Berlin},
    Note = {Neue Folge, Heft 2},
    Number = {18},
    Publisher = {Akademie–Verlag},
    Series = {Vor\-der\-a\-si\-a\-ti\-sche Schriftdenkmäler der Kö\-nig\-lich\-en Mu\-se\-en zu Berlin},
    Shorthand = {\textsc{vs}~18},
    Title = {Altbabylonische Rechts- und Wirtschaftsurkunden},
    Year = {1973}}

@book{VS:13,
    Author = {Hugo H. Figulla},
    Language = {german},
    Location = {Leipzig},
    Number = {13},
    Publisher = {J.\,C. Hinrichs’sche Buchhandlung},
    Series = {Vorderasiatische Schriftdenkmäler},
    Shorthand = {\textsc{vs}~13},
    Title = {Altbabylonische Verträge},
    Year = {1914}}
}
\end{filecontents}

\addbibresource{Aw.bib}

\begin{document}

\frontmatter
\tableofcontents

\mainmatter
\chapter{Test}
Dummy citation one.\autocite[10]{VS:13} Dummy citation two.\autocite[18]{VS:18}

\backmatter
\printshorthands
\printbibliography

\end{document}

I require the shorthand list to be in the frontmatter. However, if I move the line \printshorthands right after \tableofcontents, the shorthand list vanishes altogether together with its table of contents entry. I have no idea what to do to get the desired effect.

7
  • 3
    You are using refsection=chapter. All your citations are in chapter 1. So when you use \printshorthands in chapter 1, it works. But when you have \printshorthands before chapter 1, there are no citations in that section, so the biblist is empty. Perhaps using refsegment=chapter will suit you better. Oct 15, 2017 at 9:44
  • @DavidPurton A hold-over from copying from another book-in-progress which I failed to appreciated. Thanks for pointing me in the right direction. Oct 15, 2017 at 14:23
  • @DavidPurton Do you want to write down an answer. If you focus on the difference between refsections and refsegments and explain it in more detail, the answer could be useful to a wider audience.
    – moewe
    Oct 16, 2017 at 13:34
  • @moewe I was unsure what to do at this point as I thought this should be closed off but I'm not the one who solved the problem. In my particular case it turned out I didn't need either option. If there's an appropriate response on my part I'd be glad to know it as I have another 'open' question outstanding solved by someone else. Oct 16, 2017 at 17:44
  • I'd just wait for David to respond. If he wants to write an answer, you can accept and upvote it. If he thinks that an answer is not needed here, you can opt to delete the question if you additionally think that it won't benefit a wider audience. The benefit for others depends a lot on the spin of the answer.
    – moewe
    Oct 16, 2017 at 17:47

1 Answer 1

4

The reason you don't get anything in your list of abbreviations when you put it in the frontmatter is because you are passing refsection=chapter to biblatex-chicago. This option means that you get a completely separate bibliography for every chapter (including one for anything that comes before chapter 1).

In you MWE, all your citations are in chapter 1 as is your bibliography and list of abbreviations, so everything is printed. When you move your list of abbreviations before the start of chapter 1, there are no citations in this section, so nothing is printed in the list of abbreviations.

You could either remove refsection=chapter completely if you just want one bibliography and list of abbreviations for the whole document, or you could switch to using refsegment=chapter which will still allow you to produce a bibliography for each chapter, but also allow a list of abbreviations (and bibliography) for the whole document.

Here's some examples illustrating what is going on.

Using refsection=chapter

\documentclass[article]{memoir}
\pagestyle{empty}
\setlrmarginsandblock{1.5in}{1.5in}{*}
\setulmarginsandblock{1in}{1in}{*}
\checkandfixthelayout
\usepackage[refsection=chapter]{biblatex-chicago}
\addbibresource{biblatex-examples.bib}
\begin{document}
% refsection=0
\printbiblist{shorthand}% no citations in this section, so nothing printed
\chapter{Chapter 1}
% refsection=1
\nocite{bertram,doody,kant:kpv}
\printbiblist{shorthand}
\printbibliography
\chapter{Chapter 2}
% refsection=2
\nocite{doody,gillies,kant:ku}
\printbiblist{shorthand}
\printbibliography
\end{document}

refsection=chapter

Using refsegment=chapter

\documentclass[article]{memoir}
\pagestyle{empty}
\setlrmarginsandblock{1.5in}{1.5in}{*}
\setulmarginsandblock{1in}{1in}{*}
\checkandfixthelayout
\usepackage[refsegment=chapter]{biblatex-chicago}
\addbibresource{biblatex-examples.bib}
\begin{document}
% refsegment=0
\printbiblist{shorthand}% print all abbreviations from all segments
\chapter{Chapter 1}
% refsegment=1
\nocite{bertram,doody,kant:kpv}
% print abbreviations and bibliography from the current segment (1)
\printbiblist[segment=\therefsegment]{shorthand}
\printbibliography[segment=\therefsegment]
\chapter{Chapter 2}
% refsegment=2
\nocite{doody,gillies,kant:ku}
% print abbreviations and bibliography from the current segment (2)
\printbiblist[segment=\therefsegment]{shorthand}
\printbibliography[segment=\therefsegment]
\end{document}

refsegment=chapter

Using refsection=none and refsegment=none (default)

\documentclass[article]{memoir}
\pagestyle{empty}
\setlrmarginsandblock{1.5in}{1.5in}{*}
\setulmarginsandblock{1in}{1in}{*}
\checkandfixthelayout
\usepackage{biblatex-chicago}
\addbibresource{biblatex-examples.bib}
\begin{document}
\printbiblist{shorthand}% print all abbreviations
\chapter{Chapter 1}
\nocite{bertram,doody,kant:kpv}
\chapter{Chapter 2}
\nocite{doody,gillies,kant:ku}
\printbibliography% print all bibliography entries
\end{document}

refsection=none and refsegment=none

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .