2

I am using scrreprt KOMA-class with biblatex.

I have my citations and bibliography set up as desired:

enter image description here

However, one detail is missing: I would like the authors in the bibliography to be both small caps AND bold (right now, they are small caps only.)

Is there a way to achieve this?

I have spent some time doing trial and error and scanning the biblatex documentation, but did not find what I needed.

Thanks in advance for your help.

\documentclass[12pt, twoside, openright, chapterprefix, numbers=noenddot]{scrreprt}

\usepackage[left=2cm,right=2cm,top=2cm,bottom=2cm,headheight=15pt,includeheadfoot]{geometry} 

\usepackage[automark,headsepline=off]{scrlayer-scrpage}  % use document with \pagestyle{scrheadings}

%%% Deutsche Zeichen und Schrift
\usepackage[ngerman]{babel} % deutsche Trennregeln
\usepackage{lmodern}    % fixes bug with \usepackage[T1]{fontenc}; ändert Schriftart zudem in Latin Modern
\usepackage[T1]{fontenc}   % für europäische Autoren ratsam; % wichtig für Trennung von Wörtern mit Umlauten
\usepackage[utf8]{inputenc}
%\usepackage[ansinew]{inputenc}
\usepackage{textcomp}

\usepackage[T1,hyphens]{url}
\usepackage{hyperref}   
\hypersetup{colorlinks=true, linktocpage=true,  linktoc=all,    
    %linkcolor=beierblau, 
    citecolor=beierblau, filecolor=beierblau, urlcolor=beierblau, breaklinks=false,
    bookmarksopen=true, colorlinks, linkcolor = black}
\usepackage[all]{hypcap}        % needed to help hyperlinks direct correctly;
\usepackage[numbered]{bookmark}

\usepackage{xcolor}
\definecolor{beierblau}{RGB}{0,0,255}


%%% bibliography
\usepackage[style=authoryear, backend=biber,
%alphabetic --> see https://de.sharelatex.com/learn/biblatex_bibliography_styles; https://de.sharelatex.com/learn/Biblatex_citation_styles
 refsegment=chapter, % benutze automatisch Kapitel als Biobliographie-Abschnitte... (refsegment makes sure that identical references have the same label throughout the whole document; as opposed to refsection)
% scauthors = true 
 ]{biblatex}
\ExecuteBibliographyOptions{firstinits=true,maxcitenames=1,maxbibnames=999,isbn=false,doi=false,url=false,labeldate=true,uniquelist=minyear}

%% set borders
\setlength{\bibitemsep}{12pt}
\setlength{\bibhang}{0cm}
%\setlength{\bibhang}{0.2cm} rückt mehrere Zeilen ein

%% fix sorting
\DeclareNameAlias{sortname}{last-first}

%% no "quotes" around titles of chapters/article titles; text-style of title in bibliography 
\DeclareFieldFormat[article, book, inbook, incollection, inproceedings, misc, thesis, unpublished]{title}{\textit{#1}}    % \textit for italic style titles; \textnormal for regular text

%% titles of articels and incollections not italic
\DeclareFieldFormat[article]{journaltitle}{\textnormal{#1}}
\DeclareFieldFormat[incollection]{booktitle}{\textnormal{#1}}

%% separation style between authors
\AtBeginBibliography{%
    \renewcommand*{\multinamedelim}{\addsemicolon\space}%
    \renewcommand*{\finalnamedelim}{\addsemicolon\space}%
}

\DefineBibliographyStrings{ngerman}{%
    andothers = {et\addspace al\adddotspace},%
    andmore = {et\addspace al\adddotspace},%
}

%% Authors in small caps in citation and bibliography
\renewcommand*{\mkbibnamelast}[1]{\textsc{#1}}
\renewcommand*{\mkbibnameprefix}[1]{\textsc{#1}}

%% Format of punctuation after author+year
\renewcommand*{\labelnamepunct}{
%   \mkbibbold
    {\adddotspace}}     % \addcolon\space

%%Add bib resource
\addbibresource{Literatur/citavi.bib} 


%%% Example bibliography
\RequirePackage{filecontents}
\begin{filecontents}{\jobname.bib}
    @book{Giancoli,
        Author    = {Douglas C. Giancoli},
        Publisher = {Pearson},
        Title     = {Physics for Scientists \& Engineers},
        Year      = {2014},
        Date-Added = {2015-10-05 12:23:12 +0000},
        Date-Modified = {2015-10-05 12:23:50 +0000},
    }
\end{filecontents}
\addbibresource{\jobname.bib}


\begin{document}

\chapter{Test-Kapitel}
Some \cite{Giancoli} text \autocite{Giancoli}

\printbibliography[segment=\therefsegment, heading=subbibintoc, title={Literatur}]  


\end{document}
3

To change the used font for the family name of the entries in the bibliography only use the following just before your \printbibliogrphy:

\renewcommand*{\mkbibnamefamily}[1]{\textsc{\textbf{#1}}}
\renewcommand*{\mkbibnameprefix}[1]{\textsc{\textbf{#1}}}

Note that the correct macro name is \mkbibnamefamily not \mkbibnamelast. The latter is just for legacy support and doesn't work after \begin{document}. But lmodern doesn't support bold smallcaps.

The biblatex commands for the formatting of names are:

\mkbibnamefamily
\mkbibnamegiven
\mkbibnameprefix
\mkbibnamesuffix

Note: To get something that looks like bold smallcaps, you might use the contour package if your font doesn't support them, but be aware that this might result in ugly looking output:

\usepackage{contour}
\contourlength{0.01em}% adjust how bold it'll get
\renewcommand*{\mkbibnamefamily}[1]{\contour{black}{\textsc{#1}}}
\renewcommand*{\mkbibnameprefix}[1]{\contour{black}{\textsc{#1}}}

This results in the following (upper is with contour, the lower is \textbf{Giancoli} for comparison) enter image description here

1

The tecnical answer is to add \textbf{...} to the definition for:

%% Authors in small caps in citation and bibliography
\renewcommand*{\mkbibnamelast}[1]{\textbf{\textsc{#1}}}
\renewcommand*{\mkbibnameprefix}[1]{\textbf{\textsc{#1}}}

but the problem is your used font family latin modern. It does not support a font for bold and small caps.

To get that displayed you need to use a font supporting a font for bold and small caps ... And sorry, I do not know a font supporting this ...

Your code has some errors (useage of depreciated options). Please see the following corrected MWE (see <====== for important code changings, and please see that I changed the order of called packages!):

%%% Example bibliography
\RequirePackage{filecontents}
\begin{filecontents}{\jobname.bib}
    @book{Giancoli,
        Author    = {Douglas C. Giancoli},
        Publisher = {Pearson},
        Title     = {Physics for Scientists \& Engineers},
        Year      = {2014},
        Date-Added = {2015-10-05 12:23:12 +0000},
        Date-Modified = {2015-10-05 12:23:50 +0000},
    }
\end{filecontents}


\documentclass[%
  12pt, twoside, openright, chapterprefix, numbers=noenddot
]{scrreprt}

\usepackage[%
  left=2cm,right=2cm,top=2cm,bottom=2cm,headheight=15pt,
  includeheadfoot
]{geometry} 

\usepackage[automark,headsepline=off]{scrlayer-scrpage}  % use document with \pagestyle{scrheadings}

%%% Deutsche Zeichen und Schrift
\usepackage[ngerman]{babel} % deutsche Trennregeln
\usepackage{lmodern}    % fixes bug with \usepackage[T1]{fontenc}; ändert Schriftart zudem in Latin Modern
\usepackage[T1]{fontenc}   % für europäische Autoren ratsam; % wichtig für Trennung von Wörtern mit Umlauten
\usepackage[utf8]{inputenc}
\usepackage{textcomp}

\usepackage{xcolor}
\definecolor{beierblau}{RGB}{0,0,255}

\usepackage[T1,hyphens]{url}

\usepackage{csquotes}
\usepackage[% 
  style=authoryear, 
  backend=biber,
  refsegment=chapter, % benutze automatisch Kapitel als Biobliographie-Abschnitte... (refsegment makes sure that identical references have the same label throughout the whole document; as opposed to refsection)
% scauthors = true 
]{biblatex}
\ExecuteBibliographyOptions{%
  giveninits=true, % <==================================================
  maxcitenames=1,maxbibnames=999,
  isbn=false,doi=false,url=false,
  labeldateparts=true, % <==============================================
  uniquelist=minyear
}
\addbibresource{\jobname.bib}

\usepackage{hyperref}   
\hypersetup{colorlinks=true, linktocpage=true,  linktoc=all,    
    %linkcolor=beierblau, 
    citecolor=beierblau, filecolor=beierblau, urlcolor=beierblau, breaklinks=false,
    bookmarksopen=true, colorlinks, linkcolor = black}
\usepackage[all]{hypcap}        % needed to help hyperlinks direct correctly;
\usepackage[numbered]{bookmark}


%% set borders
\setlength{\bibitemsep}{12pt}
\setlength{\bibhang}{0cm}
%\setlength{\bibhang}{0.2cm} rückt mehrere Zeilen ein

%% fix sorting
\DeclareNameAlias{sortname}{family-given} % <===========================

%% no "quotes" around titles of chapters/article titles; text-style of title in bibliography 
\DeclareFieldFormat[article, book, inbook, incollection, inproceedings, misc, thesis, unpublished]{title}{\textit{#1}}    % \textit for italic style titles; \textnormal for regular text

%% titles of articels and incollections not italic
\DeclareFieldFormat[article]{journaltitle}{\textnormal{#1}}
\DeclareFieldFormat[incollection]{booktitle}{\textnormal{#1}}

%% separation style between authors
\AtBeginBibliography{%
    \renewcommand*{\multinamedelim}{\addsemicolon\space}%
    \renewcommand*{\finalnamedelim}{\addsemicolon\space}%
}

\DefineBibliographyStrings{ngerman}{%
    andothers = {et\addspace al\adddotspace},%
    andmore = {et\addspace al\adddotspace},%
}

%% Authors in small caps in citation and bibliography
\renewcommand*{\mkbibnamefamily}[1]{\textbf{\textsc{#1}}} % <===========
\renewcommand*{\mkbibnameprefix}[1]{\textbf{\textsc{#1}}} % <===========
%\renewcommand*{\mkbibnamefamily}[1]{\textsc{#1}}
%\renewcommand*{\mkbibnameprefix}[1]{\textsc{#1}}

%% Format of punctuation after author+year
\renewcommand*{\labelnamepunct}{
% \mkbibbold
  {\adddotspace}}     % \addcolon\space


\begin{document}

\chapter{Test-Kapitel}
Some \cite{Giancoli} text \autocite{Giancoli}

\printbibliography[%
  segment=\therefsegment, 
  heading=subbibintoc, 
  title={Literatur}
]  

\end{document}
  • That won't work (at least not if used after the preamble so that it only affects the bibliography). – Skillmon Oct 15 '17 at 14:27
  • Do you get bold small caps in the document at all? Also, I think the intended use is in the preamble. – Oleg Lobachev Oct 15 '17 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.