1

The animate code will compile but will not run. Have tried with the newest Acrobat Reader and version XI.

The example here is taking from texAmple.tex: http://www.texample.net/tikz/examples/sine-and-cosine-functions-animation/

\documentclass[10pt]{beamer}

\usepackage{tikz}
\hypersetup{pdfpagemode=FullScreen}
\usepackage{ifthen}
\usepackage{animate}
%
\usetheme{Warsaw} 
\usecolortheme{whale}
%
%
%
\newcounter{angle}
\setcounter{angle}{0}
%
\begin{document}
%
%
%
\begin{frame}[fragile]{Sine and Cosine functions}
\begin{center}
\begin{animateinline}[loop, poster = first, controls]{30}
%
\whiledo{\theangle<359}{
%
    \begin{tikzpicture}
    % Axis
    \draw[thick,->,blue] (-3,0)--(3,0) node[below] {$x$}; % x axis
    \draw[thick,->,blue] (0,-3)--(0,3) node[left] {$y$}; % y axis
    \draw[red,thick] (0,0) circle (2.5cm);
    \node[red,below] at (2.6,0) {1};
    \node[red,above] at (0.1,-2.5) {1};
    %
    \draw[ultra thick,cyan] (0,0) -- (0,0 |- \theangle:2.5cm); % UpOn x axis
    \draw[ultra thick,orange] (0,0) -- (\theangle:2.5cm |- 0,0); % UpOn y axis
    %
    \draw[densely dotted,orange] (\theangle:2.5cm) -- (\theangle:2.5cm |- 0,0); % vertical line
    \draw[densely dotted,cyan] (\theangle:2.5cm) -- (0,0 |- \theangle:2.5cm); % horizontal line
    \draw[ultra thick,red,->,rotate=\theangle] (0,0) -- (2.5,0); 
    \node[red,orange,right] at (0,-3.5) 
            {\footnotesize$\cos(\theangle^{\mathrm{o}}) = \pgfmathcos{\theangle}\pgfmathresult$};
    \node[red,cyan,right] at (0,-3.1) 
            {\footnotesize$\sin(\theangle^{\mathrm{o}}) = \pgfmathsin{\theangle}\pgfmathresult$};
    \end{tikzpicture}
    %
    \stepcounter{angle}
    \ifthenelse{\theangle<359}{
            \newframe
    }{
            \end{animateinline}
    }
}
\end{center}
\end{frame}
%
%
%
\end{document}¨

It is seen that the code compiles, however it not possible to run the animation.

enter image description here

Hope that someone can help?

closed as unclear what you're asking by user36296, Stefan Pinnow, Andrew, TeXnician, CarLaTeX Oct 29 '17 at 15:28

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Remove the spanish option, or load \usetikzlibrary{babel}. – Ulrike Fischer Oct 16 '17 at 8:36
  • Is your file encoded in ansinew? For most editors utf8 is the default. You don't need graphicx or color with beamer, as beamer already provides this functionality. – user36296 Oct 16 '17 at 8:53
  • 2
    Works for me. (compiled with pdflatex) – AlexG Oct 17 '17 at 7:26
  • 1
    BTW, the \whiledo approach for generating parameterized frames is obsolete, \multiframe should be used instead. – AlexG Oct 17 '17 at 12:52
  • How are you compiling? Which engine? Which version? – user36296 Oct 20 '17 at 15:15